asked Jun 21 '17 at 08:39 by Hietala (21)

edited Jun 25 '17 at 15:17

1
1

I've used Bitwig 1.3 normally with no huge problems but when I tried launching Bitwig today Ubuntu gave me an error message that said something along the lines of Bitwig is not working and gave me the option to send feedback. I didn't. I tried again and the same thing happened so I clicked to send feedback. Nothing happened.

After this I tried launching Bitwig again and now it only briefly flashes the Bitwig pop-up after which nothing happens.

I tried restarting my computer. I've made no changes to anything since I last used Bitwig. I checked System Monitor and there's no instance of Bitwig running there. I tried searching around but couldn't find a similar problem.

Here's what I'm running: Ubuntu 16.04 64-bit | AMD Ryzen 5 1400 Quad-Core Processor × 8 | 7,8 GB RAM | 25 GB SSD + 120 GB SSD | Focusrite Scarlett 2i2

Please let me know if you have a similar problem or if you need more information.

12next page »

Problem is solved with the latest Ubuntu update.

Thank you for the support :)

link

answered Jul 03 '17 at 17:11 by Hietala (21)

The problem is in the new kernel Linux 4.8.0-56-generic. I'm same the problem and I have boot the computer with the kernel Linux 4.8.0-54-generic. Then Bitiwig start without problems.

I do not know who the problem is, whether bitwig or linux or both

link

answered Jun 21 '17 at 19:37 by Joan (56)

To @Hietala and @klaasbijland:

You don't replace a new kernel with an old like regular updates, it's installed alongside. So to boot an earlier kernel you don't need to uninstall the newest, just select "advanced options" in the GRUB menu during boot, then select the previous kernel version. There should be at least one earlier, probably several unless you've run autoremove (apt-get autoremove) to remove earlier kernels. But there's always the option to revert to the former kernel version unless you manually uninstall the previous version (and you never should).

link

answered Jun 22 '17 at 12:13 by beamboom (70)

GRUB doesn't show up in my boot up. It just goes straight to Ubuntu log in screen. I don't want to be downgrading to older kernels if there's a better solution. But if there's no solution I think I'll do this. Thank you, Joan and beamboom

  — (Jun 25 '17 at 15:02) Hietala

It's on all kernel versions. 4.4, 4.8, 4.9, ... I have the same problem on both clear supported Ubuntu 16.04 and debian testing (stretch) after an apt-get upgrade.

Reverting the kernel back to the second to last level works, but is only a workaround as you are stuck at that kernel version. They should patch the software.

Apparently adding the line "export JAVA_TOOL_OPTIONS=-Xss2560k" to the end of the /home/yourusername/.bashrc file or executing it on the command line before manually executing bitwig-studio also fixes the problem...

link

answered Jun 22 '17 at 20:44 by oli4vr (31)

I'm really cautious when it comes to tampering with files like that. I'm not a very advanced user so I don't want to make a lot of manual changes if I don't have to.

But I'll keep this in mind if no other option pops up, thank you!

  — (Jun 25 '17 at 15:05) Hietala

@Joan and your point is ?????? The kernel devs broke many programs with this update, I fail to see how this is bitwig fault, in fact they corrected the problem in less than 24h with a minor beta release. Anyways you can use the workaround available in the KVR forum by manually setting the JVM stack parameter.

link

answered Jun 24 '17 at 02:04 by ejgallego (94)

I have today (after security update) the same problem !? Yesterday it was running fine!

Ubuntu Studio 16.04 with KX Repo.

link

answered Jun 21 '17 at 12:21 by klaasbijland (43)

I'm only now installing the last OS update on my system. I took a picture of the list of the update, but don't have enough Karma points to upload a picture here... Don't know how to get it in text format.

  — (Jun 21 '17 at 13:15) Hietala

I reverted back to kernel 4.4.0.79 and Bitwig is running again. So it is the kernel update that is causing problems :)

Hope that helps anyone :)

link

answered Jun 21 '17 at 13:43 by klaasbijland (43)

edited Jun 21 '17 at 13:45

What would be the most newbie-friendly way to do that? The tutorials I've found seem intimidating to me. I'm currently running 4.4.0-81-generic

  — (Jun 21 '17 at 19:12) Hietala

Hi Hietala,

Well i think you can best install Synaptic. This is a graphical install system :) Look in detail what is installed, remove the current kernel, and install a other one. :)

ps. to search for the kernel, type ¨Linux-¨

  — (Jun 22 '17 at 08:28) klaasbijland

BitWig 2.1.2 beta solves this issue. Download link: https://www.bitwig.com/en/download.html

link

answered Jun 23 '17 at 19:54 by ejgallego (94)

edited Jun 24 '17 at 02:01

That doesn't help much since I have Bitwig 1.3

I'm sorry, going to edit that in the original question.

  — (Jun 25 '17 at 15:16) Hietala

Correct beamboom. That's what I did.

link

answered Jun 22 '17 at 12:18 by Joan (56)

Yeah I too just now discovered that it indeed happens with different kernel versions, when I got back home, as it affects both 16.04 and 17.04 and they are on different kernel versions. How peculiar.

link

answered Jun 22 '17 at 20:48 by beamboom (70)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×26
×14
×12
×4
×2

Asked: Jun 21 '17 at 08:39

Seen: 1,131 times

Last updated: Jul 03 '17 at 17:11