asked Jul 28 '17 at 03:24 by cbfishes (61)

retagged Jul 30 '17 at 10:08

pakunoda (946)

I have Bitwig 1.3.15 on my KXStudio (Ubuntu-ish) and it has been running perfectly for quite some time.

Today I downloaded the 2.1 demo, and while it installs fine, I am not able to start the audio engine. I don't get any errors when I click it, even when running bitwig-studio from a terminal, it simply doesn't do anything.

I'm running JACK, all other JACK-enabled applications are working great.

I've tried removing (renaming) my ~/.Bitwig Studio folder thinking it could be some preferences issue. (When I run Bitwig 2.1 for the first time after that, a new ~/.Bitwig Studio folder is created, as I would expect.) I've also tried reinstalling the demo. No luck yet.

Any idea what could be causing this?

| | |

Thanks everybody!! All your comments were very helpful! I was on 14.04 but just upgraded to 16.04 and bitwig 2.1.3 works great. Thanks so much!

  — (Aug 01 '17 at 14:22) cbfishes

Update: in the KVR forum thread mentioned above, I mentioned I could fix the problem on KXStudio by copying the libmvec file needed by Bitwig.

In short, I got the libc6 package here (I took the AMD64 version),

https://packages.debian.org/sid/libc6-udeb

then extracted the libmvec-2.24.so into /lib/x86_64-linux-gnu and created a symbolic link on it, named libmvec.so.1

Bitwig's audio engine starts :-), and system wide, nothing broken to report so far. Hope this help you!

link

answered Aug 01 '17 at 10:33 by pakunoda (946)

Awesome, thanks!!

  — (Aug 01 '17 at 14:23) cbfishes

Well, I ran in the same trouble. I got a clue from user StudioDave here:

https://www.kvraudio.com/forum/viewtopic.php?f=259&t=488234

I think that KXStudio, being based on Ubuntu 14, does not provide the libmvec library required by Bitwig Studio from version 2.1.2

I have two solutions: stick to Bitwig 2.1.1 that runs fine in KXStudio, otherwise move to a more recent debian-like distribution and use the KXStudio repositories.

link

answered Jul 30 '17 at 20:55 by pakunoda (946)

To get it to work "out of the box", you are supposed to be on Ubuntu 16.04 or later. Before 2.1.2 it still worked on my 14.04 installation.

After copying the two files to the right directory, as described by pakunoda further up, Bitwig runs again on my 14.04 installation.

link

answered Aug 01 '17 at 04:47 by Cyler (346)

edited Aug 03 '17 at 12:20

Aha! Thanks!

  — (Aug 01 '17 at 14:22) cbfishes

On Debian Jessie, installing the libc6 package coming from Stretch resolves the problem.

link

answered Aug 26 '17 at 01:21 by yomguy (31)

+1 working, on KX 14.04... thanks

link

answered Sep 15 '17 at 13:50 by Blindekinder (91)

I am on Arch linux with Bitwig Demo and have been getting this a LOT. I need to make sure to have other applications that are trying to play audio like Chrome (YouTube/Soundcloud tab) closed. And sometimes that doesn't work and I'll see a little bubble popup on the top right say ".... has crashed" with an option to 'restart', which worked most recently. I don't understand why Bitwig has to have exclusive access to the audio engine but gather there is a reason.

UPDATE: I figured my issue out. I was having a lot of crackling issues which I was tinkering with settings in /etc/pulse/default.pa, specifically "[load-module module-suspend-on-idle][1]". My issues were random crackles when I wasn't even using Bitwig or playing audio at all and then a TON of crackles when I was using Bitwig, I thought they were related but they really weren't.

1st, I was getting a lot of noise in my setup with an external mixer coming out of my Thinkpad Thunderbolt dock, and the reason for that was because everything was hooked up to an ungrounded outlet. Testing a very long extension cord and got rid of a lot of my sound issues. I could still hear a faint random crackle on the system every now and then, and that was due to load-module module-suspend-on-idle being active, with the ungrounded outlet this was very loud, but now with the grounded outlet it was still detectable for instance if I turned up the volume with my keyboard, after 6 seconds I could hear the "suspend", so I had commented that out so it would never suspend. And this is where Bitwig fails. It needs to suspend so Bitwig can takeover. It must be uncommented. And then if you do still get the resource busy, just wait for it to suspend and retry the "activate audio engine" again.

Now, I still had a ton of crackling in Bitwig, but noticed it only happened when the CPU indicator was near the top and I had a lot of activated tracks/voices. So I realized only having 1 voice = lot less crackling, and eventually found the "block size" setting in audio settings. I had been tinkering with it and getting good results but then read this suggestion here that suggested 1024 (default is 256) and that seems to be doing very well for multivoice on my system.

I suspect I can make this lower if I turn on the realtime Scheduling and maybe the realtime linux kernel but for now the latency is acceptable as I am just doing midi. When I start using real analog input I will reevaluate this. https://jackaudio.org/faq/linux_rt_config.html

The TLDR of my issue was that you need to have all active audio streams stopped, no YouTube videos or anything else actively playing, you can have them open and paused but not playing, or the resource will always be busy. You must also have 'load-module module-suspend-on-idle' active and after you stop playing a song or video, you must wait about 5-10 seconds before you can "activate audio engine" again in Bitwig, just wait 10 seconds after you stopped everything.

link

answered Mar 06 at 18:52 by ElijahLynn (11)

edited Mar 06 at 21:10

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×108
×28
×8
×1

Asked: Jul 28 '17 at 03:24

Seen: 2,460 times

Last updated: Mar 06 at 21:10