asked Sep 10 '17 at 14:42 by meradium (21)

Hi there,

just upgraded to Bitwig 2 yesterday... And already stuck :)

I am sure I am missing something here, but I am unable to route two MIDI Tracks to the same VST instrument MIDI channel.... Here us what I have done:

  1. Created one Track with U-He Repro-1
  2. Crate another empty track (no device) and routed its MIDI signal to the Repro-1 Plugin on Channel 1
  3. Created yet another empty track (no device) and routed this one to the SAME Repro-1 instance, also on MIDI Channel 1

Expectation: No matter which of the two created empty tracks I select, I can play the synthesizer (aka, I have a copy of the MIDI Track).

Observation: Only ONE of the two empty tracks can talk to the Repro-1, more clearly whichever track I routed first to the plugin instance.

Why? What am I doing wrong?

Thanks, Sebastian

Update: Did the same with an instance of Kontakt... If I route the two tracks to different MIDI channels, they work as expected... If I route them to the same one (each playing differnt notes BTW - so no overlap) only the track which got first assigned to the target MIDI channel plays... the other shows activity but nothing happens...

Is this a bug or a feature?

link

answered Sep 10 '17 at 14:54 by meradium (21)

I'm not totally sure I understand how you are routing but the following works for me: First instrument track has plugin. On 2nd instrument track, click the "select output for track" button (says "Master" by default). Choose "Notes toTracks" and desired track name. Repeat for 3rd track, and so on. If I arm the 2nd or 3rd track I can play the plugin on the 1st track. And midi that I have recorded on the 2nd and 3rd tracks plays the plugin on the 1st track.

David

link

answered Sep 10 '17 at 15:19 by djx (227)

Thank you David for answering.

I followed what you described and that indeed works,... No the big question for me: Why can't I just duplicate a perfectly routed Instrument track and use this copy to also route the signal to the same MIDI channel as the original track? This must be a bug or a missing "feature".

Now I basically have to manually change the routing to the original whenever I make a copy... that's strage...

But at least this kind of workaround works.

link

answered Sep 10 '17 at 15:54 by meradium (21)

@meradium, while you duplicate the 1st track, what happens with the routing? you say you need to "manually change" it. does that mean the routing disappears? or that it's there but sends the MIDI somewhere else?

Either way it sounds like something to send to support@bitwig.com, either for Bitwig to preserve routing while copying (maybe as an option in Settings?) or to fix a bug if it looks like it's copying the settings, but in reality it doesn't.

link

answered Sep 11 '17 at 11:40 by antic604 (379)

Hi there, I have submitted my observation to support. Let's see what they say...

link

answered Sep 11 '17 at 20:26 by meradium (21)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×220
×27

Asked: Sep 10 '17 at 14:42

Seen: 755 times

Last updated: Sep 11 '17 at 20:26