asked Nov 25 '17 at 14:18 by hansfbaier (11)

edited Nov 25 '17 at 14:19

When I create a new Java controller script plugin, Bitwig generates a pom.xml which references bitwigs maven repository:

   <repository>
     <id>bitwig</id>
     <name>Bitwig Maven Repository</name>
     <url>https://maven.bitwig.com</url>
   </repository>

</repositories>

But the url https://maven.bitwig.com/ is not accessible (403 Forbidden). Therefore it is not possible to compile and build the controller script. Please fix the access rights of the repository, otherwise it will be impossible to create Java based controller scripts. (Which I prefer, because of skillset and ease of development).

Thanks

I just build my controller script and everything worked fine. Have you checked you maven configuration ~/.m2/settings.xml?

$ rm -rf ~/.m2/repository/com/bitwig 
$ mvn clean verify                  
[INFO] Scanning for projects...
[INFO] 
[INFO] ------------------------------------------------------------------------
[INFO] Building Midimix 0.1
[INFO] ------------------------------------------------------------------------
Downloading from bitwig: https://maven.bitwig.com/com/bitwig/extension-api/3/extension-api-3.pom
Downloaded from bitwig: https://maven.bitwig.com/com/bitwig/extension-api/3/extension-api-3.pom (429 B at 1.0 kB/s)
Downloading from bitwig: https://maven.bitwig.com/com/bitwig/extension-api/3/extension-api-3.jar
Downloaded from bitwig: https://maven.bitwig.com/com/bitwig/extension-api/3/extension-api-3.jar (86 kB at 426 kB/s)
[INFO] 
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ midimix ---
[INFO] Deleting /home/alinz/code/bitwig-akai-midimix/target
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ midimix ---
[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] Copying 1 resource
[INFO] 
[INFO] --- maven-compiler-plugin:3.5.1:compile (default-compile) @ midimix ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 5 source files to /home/alinz/code/bitwig-akai-midimix/target/classes
[INFO] 
[INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ midimix ---
[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] skip non existing resourceDirectory /home/alinz/code/bitwig-akai-midimix/src/test/resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.5.1:testCompile (default-testCompile) @ midimix ---
[INFO] No sources to compile
[INFO] 
[INFO] --- maven-surefire-plugin:2.12.4:test (default-test) @ midimix ---
[INFO] No tests to run.
[INFO] 
[INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ midimix ---
[INFO] Building jar: /home/alinz/code/bitwig-akai-midimix/target/midimix-0.1.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.434 s
[INFO] Finished at: 2017-11-25T14:49:34+01:00
[INFO] Final Memory: 19M/268M
[INFO] ------------------------------------------------------------------------
link

answered Nov 25 '17 at 14:51 by klingtnet (11)

Can you post your example settings file? I still get 403 forbidden.

  — (Dec 20 '17 at 00:30) hansfbaier

I am using the default settings, i.e. there is no .m2/settings.xml. Here is a project where I use the latest Bitwig Java Controller API: https://github.com/klingtnet/bitwig-akai-midimix/

  — (Dec 20 '17 at 00:37) klingtnet

Hello,

1) I do not have any issue building the default script (BTS version 2.2.3>Help>Documentation>New project) after tweeking the version in the pom.xml script (BTS dependency version 4 -> 2)

2) When I click the "https://maven.bitwig.com" I have also the 403 message...

So when you say: " the url https://maven.bitwig.com/ is not accessible (403 Forbidden)", is it when you compile 1) or just by clicking the link 2) ...?

Thanks.

link

answered Jan 02 at 04:33 by golem2020 (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×21
×5
×1

Asked: Nov 25 '17 at 14:18

Seen: 294 times

Last updated: Jan 02 at 04:33