asked Jan 03 at 15:01 by prestonj (10)

0
2

I've connected an Analog Rytm, clock sync'd over USB. BitWig Studio 2 is new to me so my first step is to sync up all my external devices properly. To do so, I record a clip of four on the floor kicks, and look at the waveform output to see if it falls on the quarter note. If not, I move the sync timing forwards/backwards and re-test.

I noticed that if I hit play (to start playing the arrangement) and then start recording a clip, the timing is what I expect (or at least that's how I was initially adjusting/testing the timing). If however I have the DAW stopped and then hit the record button on a clip (which triggers pre-roll), the timing is too early. I was able to replicate that same early timing by recording to the arrangement with pre-roll enabled.

If I turn off pre-roll, it works as expected. Also, Audio Recording Latency Compensation doesn't seem to have an effect on the behaviour.

I confirmed that pre-roll does not have an effect in Ableton Live.

This is BitWig Studio 2.2.3. I've tested and hit the same problem on both OSX (high sierra 10.13.2) and Windows 10.

I may not fully understand your current workflow, so forgive me if my answer is not a good fit. And I'm sure there must other ways to achieve the same thing. My workflow is as follows:

set rytm clock receive and transport receive both on - - set bws sync to send clock to the rytm - also in bws settings sync options set the offset to 10ms plus the latency value reported on the track with the rytm HW Instrument (I found this formula by trial and error, but so far it has always been accurate for my setup). - leave clock unchecked and latency offset 0.0 in the hw instrument - create an empty clip in the arrangement page on the track with the rytm hw instrument. Make clip length as long as you want to record for. - right click on the empty clip and choose "bounce" - pre-Fader, realtime. - wait while rytm is recorded to new audio track.

The only problem is the first beat is always late. For the type of music I make I can easily fix this after. Other than that, this works accurately and reliably.

link

answered Jan 03 at 15:42 by djx (217)

edited Jan 03 at 15:45

Thanks for the reply! Am I correct in assuming that when you say "Rytm HW instrument" you're using the overbridge VST?

I actually haven't tried the test using overbridge yet - I'm just doing a very basic midi sync. I didn't want to pollute the waters with too many variables up front.

When I have some time I'll try my same test with different hardware... and test it out with overbridge too.

  — (Jan 03 at 17:06) prestonj

I did more testing and I get the exact same problem with pre-roll when I sync my Tempest. I'm going through a MOTU Midi express 128 this time instead of USB direct to Tempest.

SPP and (not surprisingly) MTC have no effect.

link

answered Jan 04 at 03:50 by prestonj (10)

No. Overbridge is not supported on mk2 yet. I mean I use a bitwig HW Instrument device with audio input set to the rytm (which is one of the stereo inputs from my motu 8a audio interface coming into bitwig). If needed, the HW Instrument can also be usaed to send midi back to the rytm (either via usb or a midi interface - and coincidentally I also have a motu express 128 - but I have found that usb direct to the rytm has about 4ms less latency). In the setup I described I'm not using midi for any control of the rytm - other than the bitwig clock via usb from the sync settings - which is why I leave the HW Instrument timing offset set to 0.0.

link

answered Jan 04 at 04:21 by djx (217)

Any workaround ideas for this? it's making my Pre-roll without quantizing on pretty unusable.

link

answered May 10 at 23:58 by Lucasr (11)

I haven't tested recently, but the only thing that worked for me at the time was...

"I noticed that if I hit play (to start playing the arrangement) and then start recording a clip, the timing is what I expect"

Probably doesn't qualify as a work around :-)

  — (May 11 at 17:14) prestonj

I have the same problem when trying to record a synced patterns on my drumbrute. When "on the fly" recording a scene when bitwig is allready playing the timing is correct and compensations/record delay are applied. When recording with pre-roll (from stopped position) compensation/record delay seemed to be ignored so the recording starts too late and cuts off the first few ms of the pattern.

This looks like a bug...

If you turn on the metronome you can clearly hear when just playing the track everything is in sync, but when pre-roll recording the metronome is out of sync with the synced device.

Please fix this

link

answered Jul 15 at 11:58 by oli4vr (31)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×215
×23
×7
×4
×4

Asked: Jan 03 at 15:01

Seen: 395 times

Last updated: Jul 15 at 11:58