asked Jan 05 '18 at 16:38 by JoPi81 (21)

I m trying for first time ever Bitwig 2 and im loving it. I know a lot of ppl says DAW's dont make the sound and blah blah ...but I really found this daw is what I was looking for after I got into Mac and left fl studio behind. And is not about the sound ...its about the feel when recording something ...the way the midi controller interacts with the software ...thats the feel I was missing from fl studio ....is not latency either ...I dont even know how to explain it but anyways. Now , ive been a little disappointed when trying to load Real guitar and Real LPC VST 3 versions . None of this 2 make any sound at all. You can see the plugin has loaded and seems to be normal but no sound. I had tried everything from the settings to download the plugin ,reinstall it ....I mean everything . But it seems theres a problem with some vst 3 plugins out there and Bitwig. Vst 2.4 versions of this 2 loads the same way very smooth and they do play sound , record ...everything but the Vst 3 versions dont. Any suggestions very welcome.

Its the exact same for me.

Both x64 and x32 VST3 versions of the plugin show up normally, I can see midi data being transmitted to the device, but there is no sound at all. Replacing it with the VST2 version (x32 only available) and I do have sound.

Its a pity because this means I have to delete the VST3 files in order for BitWig to not hide the legacy plugins which is an extra click each time I want to add the plugin. I hope this can be fixed, but I found that VST2 is so much more stable with BitWig than VST3 is. I'm using the latest BitWig 3.0.1 at the moment.

I have for example AVS Avenger and if I use it in VST3, it works and I have sound and everything, but occasionally I run into a preset that once I press a key on my keyboard to play a sound, the plugin crashes and the audio engine is turned off immediately.

If I however use the VST2 version, all works perfectly. Some presets do give me like 1 second of audio before the VST3 version crashes though... Anyway, I don't think this is the problem for the MusicLab VST3's. I have 4 of their 5 plugins, and all 4 have this problem. I'm very certain this is a BitWig issue but I'm too new to BitWig to diagnose where the problem is situated. For all I know the VST3 has multiple outputs and I need to connect other outputs for this to work.

EDIT: Oh, this is interesting... if I add both the x64 VST3 and x32 VST2 on different tracks, and I select the VST2 track with record and play, both plugins give audio. The GUI still has no audio on the VST3, but somehow the audio is sent to both tracks. If I mute either track, the audio plays through the other track. If I select the VST3 track as record and play any note, even if the VST2 track is not muted, I still have no sound. Midi is reaching it, but audio channels are setup incorrectly. This means this is definitely an error in BitWig.

EDIT2: I'm mistaken with the previous edit. Its not that both plugins give audio, its that the audio from the VST2 is sent to both tracks. If I move the volume slider in the VST2 to very low, the audio is lowered on both tracks until I drag it all the way to 0. If the VST3 was producing sound I would be able to still hear audio with the VST2 version set to 0 volume.

link

answered Aug 07 at 01:09 by LPChip (21)

edited Aug 07 at 01:19

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1

Asked: Jan 05 '18 at 16:38

Seen: 257 times

Last updated: Aug 07 at 01:19

Related questions