asked Jan 07 at 23:00 by ozonelives (21)

edited Jan 07 at 23:01

I recently purchased a Seaboard RISE and am having difficulty getting it to work with Bitwig. I checked setting on ROLI dashboard to ensure I had the proper settings for Channel Mode (multi), MPE (On), Range (2 to 16), etc... When I go into Bitwig Option/Preferences and attempt to connect the device the application doesn't recognize it as being plugged in (Equator works with the keyboard fine) and prompts me to add a generic device. I tried to get Bitwig to work with the Generic settings, but no luck so far. I also tried to set up the Seaboard manually also to no avail. I am running Windows 10 with up to date software and firmware across the board. Any suggestions would be appreciated.

Been struggling with this for a couple of days and I think I have it figured out. I ran the Windows troubleshooter tool against the Rise and it actually came back with something useful. For whatever reason, Windows sees the Seaboard RISE 49 as an "older" USB connected device and could have problems using a USB 3.0 port. I plugged the Seaboard into one of my 2.0 ports and Bitwig now recognizes the device. Problem solved!


answered Jan 07 at 23:13 by ozonelives (21)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Jan 07 at 23:00

Seen: 151 times

Last updated: Jan 07 at 23:13