asked Mar 28 at 23:31 by ottobonn (31)

Hi all,

I'm a new Bitwig user and I love it so far. I tried the demo with some pretty demanding tracks and never had any hiccups. However, last night I updated to the new version of Bitwig and I'm noticing some severe CPU spikes in the audio engine process that cause it to miss audio buffer deadlines and generally cause the system to be choppy momentarily.

I'm running it on a year-old laptop, with an Intel Core i5-6300HQ @ 2.3 GHz, 16 GB RAM, big SSD, and Linux Mint 18.1 with 4.4.0-57-generic. For the most part, Bitwig's CPU monitor shows low utilization. In my system monitor I can see the main process using about 12% of the CPU, and the audio engine generally using another 12% or so.

The system will play back music flawlessly for some time, perhaps a minute, then suddenly the CPU usage will spike to 100% in the audio engine process. It looks somewhat like a garbage collector running, though I presume the audio engine is based on C++ and explicit memory management. The tracks I am testing contain just a few stock Bitwig instruments, and no other programs are running on my computer at the time.

Any thoughts on what causes the spikes in CPU usage? I didn't use the previous version for more than a few days, so I don't know if this issue is unique to 2.3.2.

Thanks, Travis

Hi Travis, could you please elaborate on the effect this has on the audio ? I’m having an experience where although it does seem to be a cpu loaf issue, that it still happens somewhat randomly when I’m not even changing or adding anything in the project. I would describe the sound like this. At best it is occasional clicks and pops At worst it cause complete digital noise over the audio, constant crackling and digital noise.

Thanks for your time and let’s hope we can find a solution because this shouldn’t be something we have to put up with when using a more hand capable spec computer.

Cheers Shayne

link

answered Apr 14 at 05:17 by Pspiralife (51)

I would say your description of the effect on the sound is accurate. When the CPU usage spikes, the audio clicks or becomes very garbled. I haven't had this issue on newer projects I've been working on, so it could be something I added to my previous project. I'm keeping an eye out for it happening again.

  — (Apr 22 at 20:54) ottobonn

My solution to part of my problem was to increase the buffer size. However I’m now sure that the remaining issues I’m having are due to a compatibility issue between my RME soundcard and my late model MacBook Pro

link

answered Apr 22 at 23:59 by Pspiralife (51)

Latest versions of Bitwig are aweful for CPU now!! It used to handle a lot, but now it just craps out all the time!! CPU spikes, freezes up, sounds messed up!! Tech support were absolutely useless!! They guy told me to look for an older version of Bitwig and revert to that, worst advice Ive ever had :(

link

answered Apr 26 at 23:45 by tugiedj (11)

I agree! Because of the audio engine failures I reinstalled the PC, switched off all unusable stuff in Windows 10, connected a FF UFXII, still some drop outs and by changing the buffer, Bitwig freezes for around 10 seconds. By saving the setting again the same inconveniences. CPU i7700k MB Gigabyte GA-z270-UD5.

link

answered Apr 29 at 22:56 by Lan (21)

I am also getting 'random' hangups. However, I'm not seeing any CPU spikes. Pre 2.3.2 there were no such issues. Please fix asap!

edit: Looking at the number of views this topic has shows perhaps, that this is not an isolated issue.

link

answered Apr 30 at 10:15 by Vacation (11)

edited Apr 30 at 10:18

Does adjusting vm.swappiness make a difference?

cat /proc/sys/vm/swappiness

sysctl vm.swappiness=10 # or try 1

CPU Freq scaling might also be worth exploring: https://wiki.linuxaudio.org/wiki/system_configuration

"The ondemand governor scales the frequency according to the CPU load, the more the load, the higher the frequency. But this is happening independently from the DSP load on your system so it could happen that the DSP load suddenly rises for instance, demanding more CPU power, and that the scaling daemon kicks in too late, resulting in xruns because the DSP load maxes out. A solution would be to use a CPU frequency scaling daemon that scales the frequency according to the DSP load on your system like jackfreqd or to simply disable CPU frequency scaling altogether. The latter can be achieved by setting the scaling governor to performance."

link

answered May 01 at 10:54 by RelativePrime (34)

RelativePrime's answer brings attention to the fact that the original poster is running on linux. However, I think there a few commenters, myself included, that are running either mac or win. I think the problem stated in the title spans OSs.

Specifically, I'm running a pretty beefy machine (high GHz octacore, with 32 gig ram, off of an SSD) on windows 10 pro. If there is anything I can try and give feedback on, I'd be happy to try.

link

answered May 01 at 11:16 by Vacation (11)

edited May 01 at 11:20

I HAVE THE SAME PROBLEM, BOTH IN "WINDOWS" AND IN "IOS" SINCE THEY UPDATED TO VERSION 2.3; I KNOW THAT IT IS A BITWIG PROBLEM BECAUSE PROJECTS THAT I HAVE KEPT WITH VERSION 2.2, WHEN RUNNING THEM IN THE 2.3.4 THE CPU PEAKS APPEAR, BUT ON RETURNING TO 2.2 EVERYTHING GOES FLUID,

I THINK THAT THE PROBLEM HAS TO DO WITH THE BUFER (BLOCK SIZE) MY AUDIO CARD CAN GIVE UP TO 4096 SAMPLES BUT FROM 2.3 BITWIG VERSION I CAN ONLY USE MAXIMUM 2048 SAMPLES

PREVIOUS MIND HAD ALREADY REALIZED A QUESTION TO THIS TOPIC .....

Message: The audio device could not be opened Block size not supported: 4096 is not in the range of 32 to 2048

in version 2.2, if it supports up to 4096, this message does not appear, if it is possible to solve it, because since the new update 2.3 only supports max: 2048, due to this the CPU load that I have increased, making the production more difficult

, sorry for the grammar, it was translated with google translator , my language is spanish

link

answered May 07 at 05:48 by edd910610 (11)

I'm getting lots of spikes running very little as well. I'm on IOS on a 2015 MacBook.

link

answered Jun 28 at 00:05 by andilou (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×22
×20
×5

Asked: Mar 28 at 23:31

Seen: 444 times

Last updated: Jun 28 at 00:05