asked May 09 '18 at 08:27 by pitrack (31)

2
1

Hi,

Multitouch in bitwig was working pretty well with ubuntu 17.10. I just did an ubuntu 18.04 fresh install and multitouch does not work any more. For instance the virtual keyboard recognize only one finger at a time and it is the same with the mixer...

It seems that multitouch gestures are handled by the system (zoom in / out on a libre office document for instance) so I am wondering if any of you have the same issue or if it work well for you.

Bitwig 2.3.4

I'm having the same issue. No more multi-touch and single touch is incredibly sensitive (unusable unfortunately).

link

answered May 13 '18 at 17:16 by scazan (11)

Are you / were you using Wayland?

You can try to switch to Wayland in the login window and report back.

link

answered May 17 '18 at 03:46 by ejgallego (104)

@ejgallego

Yes I was using wayland with ubuntu 17.10. Unfortunately with 18.04 I can't open a session with wayland (som ekind of freeeze happend and I can not access the UI)...

link

answered May 17 '18 at 14:52 by pitrackster (11)

@pitrackster interesting, at least we have a data point here.

I can't try now as my 1-week old Lenovo X1 Yoga has totally died, and anyways I was having so much trouble with it as to be unbelievable; I'll get back to you folks as soon as my laptop is fixed.

  — (May 17 '18 at 18:27) ejgallego

Hi !

I solved It on my computer.

List hardware : xsetwacom --list -> my touch screen has the id 12

List hardware parameters for my touchscreen : xsetwacom --list parameters 12

The gesture parameter seems to be the cause of my issue

Gesture - Turns on/off multi-touch gesture events (default is on).

Disable it : xsetwacom --set 12 Gesture off

And I have multitouch working.

Hope it will help !

link

answered May 20 '18 at 13:46 by pitrack (31)

edited May 20 '18 at 14:45

Well, in fact it is far from perfect. Disabling the gesture parameter I can play different notes one after the otherkeeping all finger on screen, but if I play a chord notes are not sustained... :(

Still not able to open a wayland session...

link

answered May 26 '18 at 16:38 by pitrackster (11)

So...

I was able to start an ubuntu session with wayland. Only doing this allow the use of 2 fingers at once... If in addition I disable gnome gestures via the DisableGesture gnome extension then multitouch works as expected

Not perfect but as I do not use gnome gestures it's ok for me

Also someone in KVR forum told me that Fedora works out of the box regarding multitouch

link

answered Aug 24 '18 at 16:13 by pitrackster (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×93
×27
×2

Asked: May 09 '18 at 08:27

Seen: 1,108 times

Last updated: Aug 24 '18 at 16:13