asked Jun 30 at 17:06 by pyrotek45 (56)

i use drum machine to trigger my drum samples (duh), but the problem is that EVERY drum sample turns on the pitch tracking in the sampler and it makes going through more than one sample a huge pain. it makes the sample-preview feature useless as every drum sound is warped during playback because it's being pitched-tracked. WHY IS IT NOT OFF BY DEFAULT? Wouldn't that make more sense?

  • 1

I'm with you pyrotek45. I have the same problem with some samples and it doesn't make sense when working with drummachine. I don't get why this is still the case. It's since I bought Bitwig (more then 2 years now) that I ask for a fix. Let's see...

link

answered Jul 07 at 23:45 by stamp (60)

edited Jul 08 at 00:20

yeah, I can't believe it hasn't been fixed yet.

  — (Jul 08 at 00:36) pyrotek45

You glossed over my opening statement agreeing that the behavior should be fixed. I simply offered a practical workaround that gets the job done right now. And if you simple build a preset Drum Machine with all 16 pads pre-loaded with that Sampler confit, you can indeed simply drag samples into the pad and go.

  — (Jul 13 at 18:20) Baphy

Since I enjoy a puzzle I looked deeper. I do have a handful of samples here and there that will force keytracking ON when dropped into Sampler, but I can find no rhyme or reason WHY. I've looked at the metadata per Windows OS, per iZotope RX6 "File Info", and per loading the WAV into Audacity and using edit Metadata.

I've even scoured a few such files with a hex editor and see nothing but the usual expected RIFF info header at the front or back of the file.

None of the files that trigger this behavior have any tempo nor key metadata buried in them. (That's why I finally checked a few with a hex editor, to make 100% certain.)

And it's not based on any tempo or key information in the filename itself, because I have PLENTY of WAV files with 2- and 3-digit numbers that Bitwig could interpret as tempo, and PLENTY of WAV files with obvious key values in the filename, in various formats. I have mahy such files that are like 120 out of a list of 150 numbered files (where the 120 represents sequence; not tempo) and Bitwig won't take the bait and set keytracking ON when that file is loaded into Sampler.

So yeah, I'm stumped. There's some inconsistent, invisible behavior here and it should be cleaned up. :)

link

answered Jul 08 at 00:31 by Baphy (139)

Im glad you understand my frustration. ive emailed bitwig tech support but they pretty much just brushed me off saying my sample's metadata was wrong and that i should tell the sample creators that their samples are wrong.

  — (Jul 08 at 00:35) pyrotek45

Just wanted to chime in here and say I'm with pyrotek45 100% on this issue.

I also find the people arguing the point with him / suggesting it's not a big deal to be completely insane, fwiw.

It's a drum machine. You load samples into a drum machine. Only one key can play the sample, therefore having Keytrack default to ON makes absolutely no sense whatsoever.

The "solution" posed by baphometrix is an absolute workflow killer. All we want to do is drag and drop samples into a drum machine and be able to start playing. Workflow matters, there's no reason this shouldn't be possible.

I have wasted so much time going through the samples in my drum machine, one by one, turning off Keytrack. It's madness, plain and simple.

And again, why would anybody want keytracking on for a drum sample that can only be triggered by ONE key???

link

answered Jul 13 at 17:47 by mholloway (91)

Regardless of the above conversations, I think perhaps you're making some mistakes in what you've observed and what you think is happening? In 2.3.4 everything works fine and as expected. (Speaking as an experienced Ableton user who's built some fairly complex drum racks in both Ableton and in Bitwig, and who regularly uses "128s" in both Ableton and Bitwig.)

Drag a kick sample with key information in its file name (e.g., Cymatics Dubstep Kick 4 - F.wav directly into an audio track. Now drag it into a MIDI track's device panel so that it's automatically embedded in a Sampler. Now drag it onto pad C1 in a Drum Machine track (which automatically places it in a Sampler on pad C1). Now create a multisample using that same kick alongside other 127 or 96 other kicks (make sure each sample spans only one key each in the zone), and create yet another Drum Machine track and load that "128" (or "97") multisample into it.

In all these cases, when you play the sample in any of the Samplers (even the one using a multisample), they all sound exactly the same as the original sample in audio clip form with NO stretching (RAW). Likewise, if you preview that same sample in the Browser, it sounds exactly the same too. Furthermore, the "Keytrack" button in each sampler instance is OFF (grayed out) by default. (Well, not in the multisample--that always defaults to Keytrack ON for every sample, but in a "128" context that doesn't matter at all because each sample is zoned to one single key--other keys play different samples.)

Let's look closer at the one track that you simply dragged the sample down into the devices panel so that it was auto-loaded into a Sampler. Keytracking is OFF. The root note for the sample shows as C3 (which is expected). When you actually play C3 or C4 or C1 or C6 or ANY note on your MIDI controller, you hear the same exact original sample. Zero pitching is happening. It's being treated as a "one-shot". Again, this is exactly what we'd expect to happen. :)

Now, let's contrast this with a longer, pitched sample like a bass loop or synth loop. Let's create a new instrument track, find a bass loop that has (ideally) both Key and Tempo information embedded it its file name. For example, AW_UltimatePhaserReese_C_2_175bpm.wav. Drag that sample into the devices panel on the track so that it's automatically embedded into Sampler. This time we see that the sample is automatically set with Keytracking ON, and the root note is C3. Again, this is EXACTLY what we'd expect to see happen: short one-shots (like drum/perc one-shots) are detected and auto-set to keytracking OFF, while longer samples are detected and auto-set to keytracking ON. Play this bass sample at C3 and it sounds exactly the same as when previewed in the browser. Play a different key and the sample is pitched up or down accordingly. And it's pitched WITHOUT any stretching applied (as if it were RAW mode), because Bitwig's Sampler doesn't do stretching (yet), like Ableton's Simpler. (For that matter, Ableton's big Sampler doesn't do stretching either.)

Again, all this is exactly what we'd expect to see. I think the only consistent gripe that most Bitwig users have is that we're waiting on Bitwig's version of Ableton's "Simpler". Or at the very least, to offer an in-Sampler "STRETCH" option to allow Sampler to also stretch the sample during keytracking (using the Stretch algorithm of our choice). It would also be very nice to be able to specify this same "STRETCH" option for any sample in a multisample zone that spans more than one note.

link

answered Jul 07 at 15:20 by Baphy (139)

edited Jul 07 at 15:57

Im sorry im not following you. My problem is simple. I want to be able to drag a sample from the browser to an empty drum machine pad, then trigger that pad and have my sample playback un altered. However this is not the case since any samples i use will automatically turn on keytracking. So when i do trigger the sample it plays the the pads note which never aligns to the root note of the sample note 99% of the time.

  — (Jul 07 at 16:37) pyrotek45

The solution is simple. Bitwig should have a setting that says " keep keytracking off for sampler when spawned in a drum machine pad" on/off. So anyone who likes the way bitwig works now wont be affected but people like me will be able to use drum machine to playback our drums like a drum machine should

  — (Jul 07 at 16:42) pyrotek45

Also im not even talking about mutlisamples so maybe you're thinking of something else?

  — (Jul 07 at 18:21) pyrotek45

Here's a video showing it working perfectly as you expect it to. No clue why it's not for you, sorry.

https://youtu.be/7rx5UpRWVSA

  — (Jul 07 at 21:24) Baphy

See my newest comment at the bottom of the thread (exceeded max reply length)

  — (Jul 08 at 00:30) Baphy
showing 5 of 6 show all

i like how this gets down voted but the problem still persist. some community.

link

answered Jul 07 at 21:56 by pyrotek45 (56)

@pyrotek45 - I have a solution (workaround) for you. Yes, Bitwig should fix this by giving us some option to override the default "helpful" behavior we currently have in Sampler. But in your specific use case (Samplers used on Drum Machine pads), there is a VERY easy and simple workaround, like so:

  1. Drop an empty Sampler onto a drum pad.
  2. In the Note container in the Sampler, add a Note Pitch Shifter note effect.
  3. In the pitch shifter, click the Oct +2 button.
  4. Now open the modulators panel for the pitch shifter and add a Keytrack modulator to it.
  5. Open the properites for the keytrack modulator, choose Relative mode, set Root to 36, and Spread to 16.
  6. Now drag the modulator arrow from the keytrack over to the Semitones control and drag it downwards to a value of exactly -16.
  7. Name the Sampler something like "DrumPad NoTrack" and save it as a preset to your User Library.
  8. Now go one step further and drag a new Drum Machine into a new track. Then drag your DrumPad NoTrack preset into each of the 16 default pads. Now save this specific Drum Machine as a preset with a name like "My DrumMachine" into your User Library.

From now on, when you want to use a Drum Machine, just drag out YOUR My DrumMachine into a track, and then drag samples over to its pads like normal. Voila. None of them will be warped regardless of what the Sampler in each pad says about Keytrack being on or off.

What all this does is very simple. When the Drum Machine sends C1 to the Sampler on each pad, the keytracker and pitch shifter turns the C1 into a C3 before it hits the Sampler waveform. When the Drum Machine sends C#1, again, it's turned into C3 when it hits the waveform, and so on, for all the 16 pads. Every single pad becomes a C3 when it finally triggers the waveform in the Sampler on that pad.

link

answered Jul 10 at 01:54 by Baphy (139)

edited Jul 13 at 19:20

Perhaps a lock/unlock for the keytrack setting would be a good solution, so that the setting is persistent while the lock is engaged. Something like this..

Okay well apparently I need more of something called Karma to upload an image.. in any case here's a dropbox link.

https://www.dropbox.com/s/xb9pcegaa3fwx51/Untitled-1.jpg

link

answered Jul 31 at 23:43 by brainturning (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×50

Asked: Jun 30 at 17:06

Seen: 509 times

Last updated: Jul 31 at 23:43