asked Aug 08 at 14:27 by Seldome (21)

edited Oct 14 at 15:50

Why UI so slow & glitchy on 5k Retina? Zooming its pain, more than 1 track in arrange it pain, full screen mode painful too. How we can use new tools, devices, if we can't work with GUI? Over two years I send it to support/bug report and nothing!

[UPDATE] Have solved this issue with Resolutionator https://manytricks.com/resolutionator/ Need to set NON-RETINA (hidpi) resolution and all works fine!

It should not be slow or glitchy if you don't max out the cpu. Did you check if your computer gets clocked down due to heat issues using the Intel power gadget? https://software.intel.com/en-us/articles/intel-power-gadget-20

link

answered Aug 09 at 14:50 by dom ♦♦ (2.0k)

It should but is it. I have iMac Late 2015 5K and its have no drop down powerful like a new MacBooks. All system works in normal mode and temperature, in my room 25 degrees in celsius. I have installed last versions of Logic Pro X and Ableton Live 10 and it works smoother and faster than Bitwig in same mode. I do not change any display settings, all using in default mode.

In 'Intel Power Gadget' system temperature is 55-60 C.

  — (Aug 09 at 17:26) Seldome

P.S. when I resize Bitwig windows to minimum all works faster than in Logic Pro and Ableton but I do not see anything in arrange window because minimum size of Bitwig window. See screenshot please: https://imgur.com/a/SJZ71Z4

  — (Aug 09 at 17:26) Seldome

Can you send us a screenshot while the UI is slow and glitchy with the Intel Power Gadget open in front of it? Also a screenshot of your display preferences of OSX would be interesting.

  — (Aug 13 at 15:05) dom ♦♦
  1. Maximum windows size - glitchy UI https://i.imgur.com/qiscPCx.png

  2. Minimum window size - smoother UI https://i.imgur.com/MYkSAvQ.jpg

  — (Aug 15 at 19:26) Seldome

At last I bought thunderbolt->hdmi cable and connect my 1080p second display (DELL) and guess what... right! On the second 1080p display Bitwig works brilliant! But if I drag Bitwig back to my iMac display all works terrible again.

  — (Aug 15 at 23:27) Seldome

I recently bought a new display (HP Envy 27s) as the second display for my iMac 27 5K. On both displays the same screen resolution is 2560x1440. And on the iMac I have glitchy and freeze UI when zooming but on the HP Envy 27s everything is great and smooth.

  — (Aug 24 at 16:19) Seldome
showing 5 of 6 show all

Why UI so slow & glitchy on 5k Retina? Zooming its pain, more than 1 track in arrange it pain, full screen mode painful too. How we can use new tools, devices, if we can't work with GUI? Over two years I send it to support/bug report and nothing!

I have the same problem! Imac 27 5k! exactly the same! Logic works fine, but bitwig slows down! it's awfully shaking!

link

answered Aug 11 at 02:19 by Gaev (11)

I also have issues with lagging graphics. I use an external 4k display through HDMI on my mid 2014 15" MBP. The CPU meter can be well under 20% when this occurs. I would love to know why this happens. It can be incredibly frustrating when your meters are a 1/2 second too slow. Likewise, these issues are not present in any other DAW I use. A real shame as I am very much hooked on Bitwig at the moment.

link

answered Aug 27 at 18:30 by Jeremysfx (38)

Add “Low Resolution” support for macOS users PLEASE!!!!!!!!!!!!!!!!!!!!! We can’t enable this in Bitwig.app “Get Info”.

link

answered Sep 28 at 15:47 by Seldome (21)

edited Oct 02 at 22:55

I know it's on Bitwig to fix this, but in the meantime here's a step-by-step instruction how to run Bitwig in low-res mode on OSX: https://www.kvraudio.com/forum/viewtopic.php?p=7109683#p7109683

  — (Oct 02 at 16:22) antic604

Here's a comparison of how it looks: https://i.imgur.com/X3Zf7g4.jpg

  — (Oct 02 at 16:24) antic604

Yeah! I will try it but unfortunately it not works for me. Bitwig still launching in the hi res ignored all editing in your instruction. Try it on 2.3 and 2.4 versions and have no changes.

  — (Oct 02 at 16:37) Seldome

Sorry to hear that. They're not mine instructions, I don't even have any Apple products so can't help. Maybe try mailing the guy who posted it? Apparently it works for him & other people that followed his advice.

  — (Oct 02 at 18:05) antic604
1

Already sent that to guys on kvr about my issue with this methods. I using Bitwig only on my second 27" external dysplay now, work as brilliant. But on iMac it’s terrible!

  — (Oct 02 at 19:48) Seldome

Hello Bitwig Team,

For testing my second display I connect it via Display port instead HDMI and I have the same laggy/freezing GUI zooming as on the iMac now! Guys you must give us setting to open your DAW in low resolution on Mac!

link

answered Oct 08 at 10:18 by Seldome (21)

edited Oct 08 at 10:29

Ok! Some results of my new tests here.

• iMac 27" 5K (Late 2015) GUI work terrify laggy/glitchy on all resolutions: 1900x600 / 2048x1152 / 2560x1440 / 2880x1620 / 3200x1800

• External display 27" 4K via HDMI (low res quality DPI picture) Works well on all resolutions.

• External display 27" 4K via Display Port (high res quality DPI picture) Works well only on 1920x1080 and 3840x2160 resolutions.

Come on guys! Do something with it, please! Low Resolution enable maybe?

link

answered Oct 14 at 01:08 by Seldome (21)

edited Oct 14 at 01:09

Have solved this issue with Resolutionator https://manytricks.com/resolutionator/ Need to set NON-RETINA (hidpi) resolution and all works fine!

link

answered Oct 14 at 02:33 by Seldome (21)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×32
×4
×2
×1

Asked: Aug 08 at 14:27

Seen: 349 times

Last updated: Oct 14 at 15:50