asked Jan 21 at 19:43 by scorr14 (11)

I am running Ubuntu based Linux Mint 19.3, and using Bitwig 2.4.3.

When I click and hold a rotating knob with the mouse cursor, I am encountering an annoying issue.

The issue occurs mouse button is depressed, and I drag downwards to rotate the knob counter clockwise. If the (invisible) cursor travels outside of the bitwig window, the rotation of the knob stops.

Considering that based on the Bitwig UI layout, most instruments are located at the bottom of the screen, most counter clockwise knob rotations fail.

I have to click > drag > release > move mouse up > click > drag > release > .... multiple times.

Another issue is that the mouse cursor is not where I left it when I release.

Is this a problem that is prevalent across all Linux Distros, or is there a linux window manager / compositor that is known to work best with Bitwig.

Hi scorr14... Sorry but I can't reproduce this behavior. All the knobs managed by Bitwig I use goes far beyond "physical" limits.

What I can find limited are VST plugins knobs, but they are managed by their own software. And as a workaround you can always use Bitwig parameter knobs, which are unaffected by limits. Hope this helps... Please upvote me if I've been useful. Fabrizio

link

answered Jan 22 at 10:47 by fsciarra62 (814)

This issue seems to be specific to Linux Mint with Cinnamon desktop. It did not symptomize on Ubuntu.

What are parameter knobs?

  — (Jan 22 at 16:36) scorr14

Parameter knobs are the knobs you can see in the Bitwig device corresponding to the VST plugin in the track... all the knobs you see are referring to a VST parameter which can be controlled by a modulation in Bitwig... very very very powerful...

  — (Jan 22 at 18:01) fsciarra62

Oh ok, I am aware of these. But in the end they will suffer the same input issues as well.

  — (Jan 22 at 18:56) scorr14

Hi scorr14, you should check how your focus policy is set up. It appears to me that you have the focus following mouse pointer, which means that if you exit a window then that window loses the focus, which means keyboard and mouse events. You might choose “click to focus” which keeps the focus assigned to a windows until you click on another, or if a new window pops up and you have choose to focus to new windows. You should have a “Setting manager” to easily choose these options or configure your window manager likewise.

I’m afraid I can’t really help with Mint. I use Ubuntustudio with xfce. If you don’t solve your problems and nobody else can help you, please let me know if I can provide further help. Best regards, Fabrizio

link

answered Jan 21 at 20:19 by fsciarra62 (814)

So just to more explicitly state what you said, I should be looking for any settings relating to mouse focus, somewhere in my Linux desktops settings? Is this correct?

link

answered Jan 21 at 20:53 by scorr14 (11)

Hi scorr14... Just I'm here, please upvote me if I'm any useful... :-D I've just re-installed 2.4.3 to check what happens on my box... I can't really reproduce your behaviour. When I mouse over a knob, the mouse pointer becomes a double up/down arrow. If I click, the mouse pointer disappears and moving the mouse makes the knob rotate following mouse moves... When I release the button, the cursor appears back where I've first clicked on the knob. In your case, if I got it right, when the """invisible""" mouse pointer virtually might exit the window, your Bitwig loses focus... Correct? Fabrizio

link

answered Jan 21 at 21:12 by fsciarra62 (814)

I can't confirm that bitwig loses focus. But I can confirm that when it leaves the window, the knob stops turning.

link

answered Jan 21 at 21:51 by scorr14 (11)

Did you manage to change the policy setup? Which windows manager are you using? Do you have other windows behind Bitwig?

link

answered Jan 21 at 21:56 by fsciarra62 (814)

I am using Linux Mint 19.1 with Cinnamon desktop. According to my research, the window manager is Muffin, which is a fork of Mutter window manager.

link

answered Jan 21 at 23:03 by scorr14 (11)

You might try to follow the link below.

It talks about scroll wheel but explains how to setup cinnamon.

Check which options you have for the focus.

If you don’t find anything, I suggest you to switch to xfce...

You can always select which window manager to use if you have installed a session manager...

Try if it helps...

https://superuser.com/questions/578489/in-linux-how-do-i-give-focus-to-a-window-using-scroll-wheel

Fabrizio

link

answered Jan 21 at 23:12 by fsciarra62 (814)

edited Jan 21 at 23:18

Turns out I was not providing accurate information.

The issue is that when the invisible mouse cursor hits the bottom of the screen, the knob rotation stops.

link

answered Jan 22 at 03:17 by scorr14 (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×103
×38
×16

Asked: Jan 21 at 19:43

Seen: 330 times

Last updated: Jan 22 at 18:56