asked Feb 24 at 22:47 by vintiquesound (21)

Hi there,

I get clicks/pops/crackles during normal playback. I don't have any more than about 15-20 audio & instrument tracks, approx 16 instances of Bitwig sampler built into one drum machine, 3 FX tracks, 15-20 third party plugins. So this is a medium to large sized project.

I've used Bitwig for a few years and have not had this issue until the last few months, roughly v. 2.4 (this is also the time in which I started using Bitwig as my main DAW and thus building bigger projects, and is after I switched audio interfaces from a Steinberg UR824 to Antelope Audio Zen Studio, so it could have nothing to do with the Bitwig version).

I have my sample rate set to 44.1kHz in my Zen Studio software and 2048 sample buffer size, Bitwig simply slaves to those values and displays 2048 buffer size and I can select Automatic sample rate or 44.1kHz (but switching to either makes no difference). The interface software allows me to switch between USB stream modes min latency, low latency, standard, relaxed, safe, extra safe > but when I change those values the audio stopped working altogether or will instead play absolutely horrid and loud noises. I've always just kept it on standard when working with all my DAWs.

I have no issues when exporting the audio, but during playback even with several plugins disabled, and only one track solo'd, and no CPU peaking (it will hit maybe 50% on average) and I still get clicks/pops/crackles. It makes no sense to me, I do exactly the same thing in a Cubase project that's 3 times as big and have no issues at all with playback (albeit I have Asio Guard activated).

Any help would be very much appreciated :)

Specs: Bitwig 2.4.3 | Windows 10 64-bit | Antelop Audio Zen Studio | Asus Z87 Sabertooth | Intel Core i7-4770K @ 3.5GHz | 16 GB Ram DDR3 SDRAM | Intel 223GB SSD for OS | Three HDD for storage | NVIDIA GeForce GTX 770 graphics card | Dual monitors at 1080p

Hi.

to my knowledge the main difference when you export audio respect when you play/record is that the converters are not used, if external hardware is not involved. I might be wrong but I suspect this.

If this were true, probably it really depends on run-time load, which is relaxed if no hardware is involved because you do not have a real deadline and processing can be faster or slower than real-time, on the need.

That sayd, have you tried with smaller buffer size? Try to enable one track at a time with a buffer around 256. Do not mute tracks, deactivate them.

This is just to understand if the problem is the load or the interface driver tout-court. Anyway 50% for one track is pretty high, expecially if you have other 14-19 tracs to enable.

I understand this does not solve the problem but might shed a light to understand what is wrong.

Ah, try also to understand if your interface is connected to a USB channel which resides on a separate pci device respect your other usb devices, or video card. You know, maybe resources are shared with other high load stuff. Just to mention...

Best regards,

Fabrizio

link

answered Feb 25 at 02:43 by fsciarra62 (814)

I am happy to have been of help.

You do not have to been so puzzled if different software react in different way to hardware configuration.

Nobody of us, apart developers and sometimes, trust me, them neither, can understand deep implicacies of hardware dependency of drivers.

Re -installing a driver might, to my knowledge, reflects in different allocation of system resources like irq, buffer space, whatever.

So, strictly speaking, if Cubase ""works"" does not directly imply tha Bitwig ""has"" to work... different scheduling policies, different irq latency due to management, whatever.

That sayd, I'm happy for you if re-installing lets you happy Bitwigging...

And forgive me for my so poor Englishwhich does not allow to be more direct and precise.

Best regards, Fabrizio

Ps. If me, like anybody elee, has been of help, an upvote is appreciated.

link

answered Feb 26 at 15:04 by fsciarra62 (814)

I think the issue has been solved. I've confirmed I was running the latest firmware and software for the Zen Studio, but decided to re-install them both and restart the computer. And just like that the issue seems to have disappeared.

The only difference I have noticed is prior to re-installing my interface software, my interface and Bitwig would run at 257 samples buffer when using Auto buffer size mode, and after the re-install running the same project they've chose to run at 800 samples. And to be clear, I would manually set the buffer size to 2048 samples and sync the sample rate to 44.1kHz and would get roughly 50% CPU load with spikes to about 70%, 80%, 90%, and 100% approx 20 times per min, 15/min, 8/min and 2/min (respectively). But the clicks/pops/crackles would range from low volume to very loud and abrasive and would occur every second or more. It was actually impossible to mix and produce because I couldn't hear what I was creating.

Anyways, I'll entertain your comments @fsciarra62 for future reference and for other's trying to solve a similar issue.

"to my knowledge the main difference when you export audio respect when you play/record is that the converters are not used, if external hardware is not involved. I might be wrong but I suspect this."

This is correct, the converters are A/D & D/A so only apply when recording and during playback.

"This is just to understand if the problem is the load or the interface driver tout-court."

It doesn't seem to be a load thing because it doesn't need to reach 100 to get the clicks/pops/crackles. I don't see how this is a driver issue, since I have no playback issues on Cubase or Ableton, or any other software (Adobe Premiere Elements, Chrome, Netflix windows app, Groove Music, Spotify, etc). To me it seems like a configuration issue, or a Bitwig issue. But after all is said and does It appears my re-installing the driver/firmware is was fixed the issue, so I'll put my foot in my mouth for now.

"Anyway 50% for one track is pretty high, expecially if you have other 14-19 tracs to enable."

The 50% CPU load I mentioned was average load with all tracks enabled, with occasional peaks to about 70%-100% every 2-4 seconds. When I disable all of my drums and effects return tracks the average CPU load would dip to about 35% with peaks to about 55%-90% so I can see the CPU usage go down as one would expect. But running through all the tracks it appears there's no single plugin or track that uses an abnormal amount of CPU.

Anyways, I'll report back if the issue returns.

link

answered Feb 26 at 08:08 by vintiquesound (21)

edited Feb 26 at 08:09

@fsciarra62

Thank you for your response/contributions. I think I understand what you mean, I was not aware that re-installing drivers could possibly change a configuration/system allocation of resources (buffer size, and whatnot).

I too am happy I can continue Bitwigging. I admire the philosophy that goes into the software, it makes things more playful and experimental and a joy to work with. Though I think still room for the software to grow and for further development of features, I'm excited for the future versions/updates.

link

answered Mar 03 at 00:32 by vintiquesound (21)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×176
×35
×27
×13
×8

Asked: Feb 24 at 22:47

Seen: 421 times

Last updated: Mar 03 at 00:32