asked May 16 at 11:44 by audiosurge (23)

ok, so I have an instrument track with some vst loaded. now I create 3 more tracks and send the output to the first instrument track. when I solo one of the new tracks, it does not work. however when I mute one of them it works as expected. what on earth am i missing here?

maybe there's a work around for what i want to achieve (which is pretty basic stuff really): Have one instrument track like NI Kontakt which can receive on multiple midi channels. Then I want other tracks to send notes to that instrument on different midi channels. AND be able to SOLO them. How does anyone else do that? It's just so common in other daws.

Ok, I have tried it and looks to me that it works.

I show you the "updated" project.

routing As you can see in the inspector, I have selected the option "Same" for parameter "To" in Channel, so that each midi input preserves its channel information.

Then each clip is on a different midi channel. You can select the clip and choose the channel in the inspector.

Then I have routed each track Note to the HW Instrument, as before.

I do not have Kontakt so I have prepared, using virtual midi connection, a link to Fluidsynth, which is simply a multichannel Soundfont player, used to render MIDI files, etc.

Then I have routed back its audio output in Bitwig. Note that also in the HW Instrument I have selected the option to keep the channel information.

Well, each midi clip is associated to a different instrument, a piano for channel 1, a guitar for channel 2, a string ensemble for channel 3. If I use Solo button or Mute button I can clearly hear that it works.

Isn't this the behavior you are looking for?

If hope to have been of help. Please, if I did not understand correctly your needs, feel free to clarify better.

If I have been of help, please upvote me (I suggest to not "award points" but use the up arrow..). And if this is a correct answer, please indicate that the issue is solved and mark this, or any other, as a solution.

Fabrizio Fabrizio

link

answered May 21 at 09:07 by fsciarra62 (794)

Ok... I have redone the test.

Actually it works.

Find here a sample project in which I have created some midi tracks and the Note output has been sent to a fourth in which I loaded a sampler with a piano. routing You can mute or solo the midi tracks and this works as expected... I don't know what I have seen before...

This is Bitwig 3.0beta2.

Hope this helps. Fabrizio

link

answered May 21 at 01:59 by fsciarra62 (794)

Yes, thank you, it now sort of works. At least it's a work-around since you have to choose the midi channel per clip. Maybe Bitwig will fix this behavior and let us set the midi channel by track. For now this will have to do I guess :)

link

answered May 21 at 10:55 by audiosurge (23)

Well, this is not completely correct. I had to assign a midi channel to the clip because they went from the clip library. If you record midi data by yourself, you can preserve the channel information choosing “Same” in the Channel mapping control in the track inspector, or remap to the channel you need. And keep into account that you have MIDI mapping/filtering device that you can add in the track chain. Hope this helps, too... :-) Fabrizio

  — (May 21 at 21:07) fsciarra62

Hi,

mute does not work on pure midi tracks. Solo does.

As a workaround you can deactivate the track.

Hope this helps.

Fabrizio

link

answered May 20 at 08:12 by fsciarra62 (794)

nope, sorry solo does not work but mute does. please read my question again, this should really be possible, if not it's a bit of a deal breaker. how does everybody else deal with this??

  — (May 20 at 11:35) audiosurge

My answer was not based on you question, but on my try on Bitwig 3.0beta2. Which version are you using?

  — (May 20 at 16:11) fsciarra62

**well your screenhsot does not reflect the issue I have. Attached is screenshot that does (hahah I can't actually upload a photo as I have less than 60 karma...well that sucks).... but here you go: https://pasteboard.co/IfEDABr.jpg

I have tested this also in This is Bitwig 3.0beta2 - same problem as before..

You have to send midi to Plugins, NOT tracks. So if you have a multi channel midi plugin like Kontakt and want to use 3 different instruments on 3 different tracks, you would send the midi over 3 different midi channels to the plugin. And when you do this, solo does not work. Bitwig support suggested to just use 3 instances of the same instrument. That's not really a solution as it would use 3 times the processing power for the same task.**

link

answered May 21 at 03:40 by audiosurge (23)

Why can’t you send the midi notes to track, preserving the channel information, choosing the “Same channel” mapping option in destination track? I do not have kontakt to test it. I might try with a midi player.

  — (May 21 at 08:12) fsciarra62

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×61
×34
×20
×15

Asked: May 16 at 11:44

Seen: 156 times

Last updated: May 21 at 21:07