asked Jun 18 '19 at 21:06 by willyvvu (21)

edited Jun 18 '19 at 21:07

Was trying to use Bitwig with JACK and xjadeo but realized that even though the timebase syncs (tempo and beat markers), the timecode (hh:mm:ss) does not.

alt text

Is this a bug?

Platform info: Bitwig 3.0 Beta 6, Ubuntu Bionic, Jack 1.9.12

Ah, after fishing around, this isn't a new observation:

  — (Jun 18 '19 at 21:09) willyvvu

I second this, running Bitwig 3.0.1 on Ubuntu 19.04, Jack 1.9.12.

Start/Stop, as well as BPM synchronization works. Transport is not transmitted/received by Bitwig. All other Programs tested work well together. Transport timecode stated by Catia (0.9.0) is respected by all other applications, while Bitwig always starts playback from its own pointer.

I'm a new user and a patch for this would be amazing for creating music for videos! I hope this'll get fixed.


answered Jul 20 '19 at 18:56 by Plyro (16)

edited Jul 20 '19 at 18:56

If it helps, I got Bitwig to sync with xjadeo through ALSA MIDI MTC clock sync.

First you need to create a virtual MIDI device:

sudo modprobe snd-virmidi midi_devs=1

Then activate ALSA MIDI bridge (e.g. in Cadence), go to Bitwig Preferences/Synchronization and activate Clock/MTC for one of the Virtual MIDI channels (first one for me), select MTC ALSA SEQ as sync mode in xjadeo and finally connect the two nodes in your JACK patchbay (Virtual Raw MIDI capture to xjadeo MTC in). I'm not able to post screenshots yet, I hope that's clear enough!


answered Jul 20 '19 at 19:29 by Plyro (16)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Jun 18 '19 at 21:06

Seen: 259 times

Last updated: Jul 20 '19 at 19:29