asked Jul 05 '19 at 21:12 by halfshavedyaks (21)

edited Jul 10 '19 at 15:58

I am evaluating the demo of BWS on linux.

I currently use Reaper.

I am finding that when playing a live software instrument from a midi keyboard that Bitwig can only manage one note without Xruns, and Reaper can manage 3 or 4 notes.

Same plugin, same keyboard input, same low latency Jack settings.

My panel CPU meter even registers a similar cpu usage in both cases, but with BWS I get xruns and with reaper i don't.

I am using a liquorix pre-empt kernel.

Now I know a fair bit about optimising for low latency performance, but in this case what is bugging me is the difference in performance between BWS and Reaper - its a deal breaker.

Since the only variable is the host DAW there must be something non-optimum in BWS. But I can't find any relevant settings in BWS to change, all that stuff is in jack and that is the same for both DAWs.

Does any one have any suggestions about what I might change?

Should there be specific real time priority settings for BWS set somewhere in the system?

EDIT: I also tested on MacOS and the difference there is much smaller - less than 10% I would guess, reaper is still better, but not by much.

12next page »

Yes I can confirm this too, using VST under linux in bitwig is causing xruns for some of them. I tried the heavy VST from Seaboard and I had xruns every +-5 sec too. Will try it in reaper to see if it's the same behaviour.

Cheers

link

answered Apr 29 at 17:44 by eeight (21)

so far for me it's been every third party vst I have tried from a wide variety of developers.

of course whether the spike actually causes an xrun will depend on buffer settings and the spikes do vary a bit in height - although the max load value reported in bitwig's "DSP performance graph" seems to always be around 9ms.

even more strange and distressing is the spikes continue even when the plugin is turned off and only disappear when it is removed from the signal chain entirely.

seems to me like a serious bug in the vst handling.

when I turn off a third party vst the average dsp load drops as one would expect, but the spikes continue. I've only found one plugin where the spikes stop completely when it is in the signal chain but turned off.

link

answered Apr 29 at 19:00 by halfshavedyaks (21)

Please halfshavedyaks, write to support@bitwig.com signaling the behavior... I thank you very much for all your effort. I've had troubles while recording many tracks (ex. 10 tracks for drums) and a lot of synths playing the base but didn't realize any time-correlation trouble, but noticed that the load was not so significant. Hope this will get to some point. Please report any answer you get. Thank you again. Fabrizio

  — (Apr 29 at 19:22) fsciarra62

Hi,

I upgraded yesterday from bitwig 2.x to 3.x and experiencing xruns (same setup, just updated bitwig). I even double the buffer in jack (from 128 to 256) and still experiencing xruns.

BW team, you should consider trying to find what is eating our cpu. Very easy to reproduce, install BW 2 - add some poly, fm synths compare the dsp graph with BW 3.

Would be happy to buy the full version if you find the solution. Cheers

link

answered Jul 11 '19 at 20:47 by eeight (21)

edited Jul 12 '19 at 01:14

I was originally testing 2.5 but I have now tested BWS3 and they seem much the same. Exactly which version of BWS did you have better performance with? Was it earlier than 2.5?

  — (Jul 12 '19 at 03:22) halfshavedyaks

2.5.1 are you pushing BWS to the lowest latency possible (setting jack as low as possible without having xruns, then update to BWS 3.x == xruns (again same setup + doubling the buffer == xruns too, so for me it's less optimized in BWS).

  — (Jul 12 '19 at 03:30) eeight

my original comment was about 2.5.1 I had poor performance on that also.

I was testing by seeing how many notes I could play without xruns on a very cpu intensive synth sound (using u-he Diva)

I was testing mostly at 88.2khz 128 samples, which is a quite challenging setting. But the performance was obviously better on reaper on other settings too.

  — (Jul 12 '19 at 11:35) halfshavedyaks

What kind of hardware are you running? How much memory? I would say 8GB min is needed if you want to do more than basic stuff. See this thread for setting up Jack: http://mikelococo.com/2017/09/usb-audio-latency/ Try 44.1 khz, 256 frames, 3 buffers and go from there. Make sure "realtime" is checked in qjackctl. Does Guitarix running by itself work OK? You can also try running directly to ALSA in the Bitwig settings.

link

answered Jul 14 '19 at 22:28 by dirtcooker (21)

Yes 8GB of RAM with a i7 - 4 cores. Like I said the same setup is working fine in BWS 2.5.x - the new version is causing xruns. Surely more CPU hungry. All other software are running fine (huge patch in pure data, guitarix etc). I reverted back to BWS 2.5.x for now.

link

answered Jul 15 '19 at 02:36 by eeight (21)

Thanks for the post and nice to see this here. Picsart is one of the most feature-rich photo editing application for Android. how you can install and download picsart for pc full version is given here.

link

answered Mar 18 at 08:26 by stevride (7)

Thanks for the post and nice to see this here. Losing your extra body weight is now easy with the latest weight loss supplement named Leptitox. Read our in a detailed Leptitox Reviews to use it. leptin function

link

answered Mar 28 at 12:12 by miltonwill (7)

well, thanks for the replies, I am now trying the latest bitwig 3.1.3 demo and still having the same problem.

none of the answers actually addressed the issue at all which is the DIFFERENCE in performance between bitwig and reaper.

since jack, my hardware and system configuration and the plugin concerned are all EXACTLY THE SAME the difference in performance must be due to the difference between bitwig and reaper.

asking about my system specs is also irrelevant since I get excellent performance in reaper. (FWIW it's a kaby lake quad core i5 with 16Gb ram)

advice on how to get adequate performance in bitwig is irrelevant and subjective - no doubt if I use a less demanding plugin and longer buffer sizes I can make it usable - what concerns me is that bitwig is performing much less well than reaper, and that that difference is not replicated (as much) on macOS

so the options are:

  • bitwig just doesn't perform as well as reaper on linux (which would be a great shame because I love the MPE and microtuning stuff and I'm on the verge of buying it) if this is true it would suggest something wrong with the linux build of bitwig.

OR

  • the optimum jack and system settings for bitwig are different from the optimum settings for reaper. I can't imagine why that might be, but maybe it is possible.

OR

  • there's a setting somewhere in bitwig itself that I need to change.

EDIT I should add, I get OK performance with phase 4, but of course I can't compare that in reaper - it is possible that problem only applies to 3rd party plugins

link

answered Apr 29 at 17:02 by halfshavedyaks (21)

edited Apr 29 at 17:24

OK, I just found the performance graph in bitwig.

this shows that I have plenty of power - load average with Diva silent is 0.2ms and rises to 0.6ms when playing several notes. since deadline is 5.3ms at current settings there should be no problem.

however, the graph also shows a spike exactly every 5 seconds with Diva running. this goes away when diva is turned off. It is these spikes causing my xruns (at least at the moment)

so I think there is a bug of some sort in the vst handling in bitwig (the exact same plugin runs fine in reaper)

in short it is some sort of bug or glitch, not a lack of resources.

I've tried different plugin sandboxing settings but they make no difference.

EDIT I have found that all other third party vsts show the same problem - so far I've tried diva, helm, tal noizemaker, u-he ace, u-he repro

I think it also does it with third party audio effects too... checking that next.

link

answered Apr 29 at 17:37 by halfshavedyaks (21)

edited Apr 29 at 18:22

confirmed - ALL third party vsts cause spikes up to 9ms load - so if buffers are larger than 9ms it squeaks through. but sincvce my average load is well under 1ms it seems crazy to have to increase the buffer just to accomodate the spikes.

so my question is somewhat modified: what could be causing spikes in cps load in bitwig on 3rd party vsts only.

it has to be something about BWS vst handling, or possibly midi handling.

the periodicity of the spikes varies but it is generally every 4-8 seconds.

I'm currently using this kernel: 5.0.0-37-lowlatency #40~18.04.1-Ubuntu SMP PREEMPT Thu Nov 14 12:51:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

link

answered Apr 29 at 18:32 by halfshavedyaks (21)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×108
×9
×2
×1

Asked: Jul 05 '19 at 21:12

Seen: 685 times

Last updated: Apr 30 at 12:51