asked Aug 25 at 04:53 by softblastnuke (11)

I ran into a really vexing problem today. I was working on a small thing. I tried to save that thing. I pressed file -> save as, and literally nothing happened. The Bitwig window just said "new 2*".

I soil myself, regroup, then try to come up with a way to find out WTH is going on? Being unable to save is scary AF.

Nevermind how, but I found the following error, hopefully if anyone else sees it, they'll find this post:

/opt/bitwig-studio/bin/show-file-dialog-gtk3: symbol lookup error: /lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

What I figured out, is that the dpkg that ships with BWS3.0.1 contains older versions of libraries my system already had. Since I have to load BWS by the following command line:

sh -c "LD_LIBRARY_PATH=/opt/bitwig-studio/lib/bitwig-studio /usr/bin/bitwig-studio"

I solved the problem by executing:

sudo rm -f /opt/bitwig-studio/lib/bitwig-studio/*[0-9]

Now bitwig runs correctly, the save dialog appears, and I can save all my songs again.

HTH someone, took me 2 hours of dorking around to finally solve.

The answer is in the main description. Just needed to do this so I could mark it as answered.

tl;dr:

sudo rm -f /opt/bitwig-studio/lib/bitwig-studio/*[0-9]
link

answered Aug 25 at 05:01 by softblastnuke (11)

edited Aug 25 at 05:02

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×103
×33
×1

Asked: Aug 25 at 04:53

Seen: 143 times

Last updated: Aug 25 at 05:02