asked Dec 13 '19 at 15:24 by FergusL (21)

Hello, this is not really a question, I received a reply from support about this limitation, I just want to leave this here and post updates.

The meat of it is that: Bitwig as is is not designed to play Audio events independently of project tempo automation.

A direct practical consequence of this is if you have a live piece over which a tempo change through automation occurs, then Audio events will not play in their original length because their duration is set relative to bar/beats and effectively to the project tempo. This was a huge limitation to me that I circumvented simply by not using project tempo automation at all.

Of the other available solutions, using the Sampler device doesn't seem fitting for the task as it requires a midi clip with a long note and/or 100% release time, and some clips might be about 7 minutes long which is a lot in ram.

My use-case is playing sound/music for a theater play. In this context the needs are a little bit different from a casual live set. The sounds are generally triggered, sometimes overlapping in time, in relation to the play, with a lesser focus on maintaining constant rhythm/tempo. Many people in this field use Live, does anybody know if it supports this kind of setup better?

As a side note there is a seemingly related bug in BWS: I have noted that if project tempo changes with automation during playback, the waveform display in the (bottom) Detail Editor panel isn't updated until the transport is stopped. This creates confusing visual feedback from the software as it shows the waveform across all the clip duration when it actually plays only for its actual duration relative to the loop length. The display is updated when stopping and shows the correct waveform. Note that the waveform is updated correctly when changing the tempo manually during playback.

Demo project : https://we.tl/t-ZhOn8V2JCK Press play, look at both Master and audio clips, tempo automation in master track and check waveform of audio clip.

Though Bitwig is definitely not aimed towards sound operators in a theatre setting, I think a couple of the needs do overlap with live music performance, which Bitwig is more geared towards. Have you tried using the clip launcher with all your sounds loaded (on separate tracks if they need to play simultaneously) with looping and launch quantization off? As long as the audio event has a stretch mode of Raw, this setup should completely ignore tempo altogether, and only wait for your input to play sounds, whether via MIDI/OSC or by clicking with your mouse. I don't know of any good way to assign cue ordering or anything, but that's probably leaning more towards features specific to sound op softwares.

link

answered Dec 30 '19 at 17:07 by jaxter184 (62)

Yes I tried what you suggested but from my tests raw audio events in launcher clips do not ignore tempo in the specific case of tempo change through automation. Manual tempo change with controller doesn't seem to be affected.

My understanding of this limitation is that the length of raw audio events is expressed in project beat/bar/tempo; if tempo increases then the actual "realtime" length will be shorter (eg. 4 bars at 120bpm is longer than at 185bpm) so the audio clip will not play entirely. Here's the project again https://mega.nz/#!xQlxGQJb!vjXwXOZwB8EPonpOJssBuIpNw_RIsDl1QQYKJB6LPDY

  — (Dec 30 '19 at 17:50) FergusL

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×86
×70
×35
×10
×4

Asked: Dec 13 '19 at 15:24

Seen: 135 times

Last updated: Dec 30 '19 at 17:50