asked Apr 01 '14 at 20:58 by davephillips (76)

edited Apr 03 '14 at 15:32

Greetings, I'm very impressed with Bitwig, I'm running the Linux version (1.0.5) on Fedora 19. I have an Akai LPK25 keyboard that appears as a MIDI In device when attached to my laptop's USB port, but I've been unable to actually trigger a sound in BW with this keyboard. I've tested it with other apps, it's fine, and I created a controller script that works for it too. Alas, still no actual connection. Am I overlooking something or is Linux MIDI I/O a known problem ? Any advice/assistance would be appreciated, thanks.

Best regards,

Dave Phillips

Please always make sure, no other program (including jack! Disable Jack's midi functionality) access your controllers, as they will lock them and BWS then cannot use them anymore.

Also check out this possibly helpful Q&A:

http://answers.bitwig.com/questions/1218/how-do-i-get-midi-inout-of-bws-on-linux

  — (Aug 03 '15 at 14:21) riot ♦♦

I created a working script for the LPK25, it's now autodetected, can trigger notes on BW's synths, and records perfectly. The script ignores all other functions, please feel free to expand it if you'd like to have the units other functions working.

Script here:

http://linux-sound.org/misc/lpk25.control.js

Best,

dp

link

answered Apr 03 '14 at 15:35 by davephillips (76)

Bitwig does receive MIDI input from my MIDI keyboard (Axiom 25), including knobs, drum pads. That's just on the "Generic Keyboard + 8 Device Knobs" setting. Thing is, it only works without the MIDI bridge (a2jmidid) running and I do not see any connections being made or even possible in the patch bay, but it works. Therefore I do not have a2jmidid loaded at startup any longer, but only run it when I need it for another DAW or soft synth. Not ideal by a long shot, but something I can work with for now.

link

answered Apr 03 '14 at 03:49 by Cyler (296)

edited Apr 03 '14 at 04:18

yes - worked for me. Stopped the Alsa-Midi Bridge and Bitwig lets me play. And yes, Bitwig should fix that soon, so that we can work with Midi on Multiple DAWs at the same time. Thanks for you hint!

  — (Apr 03 '14 at 21:42) Nimmersatt

We cannot really fix this, it is a more general problem of jack grabbing and needing exclusive access to the controllers. You can pipe in midi from controllers using jack and a2jmidi, but the controller scripts won't work then.

  — (Aug 06 '15 at 14:06) riot ♦♦

Hey riot, Paul Davis says that it's not true that Jack needs exclusive access to the controllers. Maybe its more the case that Bitwig needs exclusive access to them? Right now, not being able to access my MIDI controller while Bitwig is listening to it is extremely limiting.

Maybe you all could re-examine this issue? Being in Berlin and all, I'd imagine there are plenty of Jack wizards around who would be willing to come help get real Linux support.

http://linux-audio.4202.n7.nabble.com/jackd-without-MIDI-tp97878p97901.html

  — (Jan 18 at 06:54) phonymacaw

I have the same problem in Linux. none of my Midi Controller work in Bitwig, however all of them are shown in the preferences and work in other DAWs. If I press a key or turn a knob, nothing happens. I am guessing this is a bug because we are not the only one with this kind of problem. http://answers.bitwig.com/questions/282/what-all-do-i-need-to-set-up-to-get-a-korg-nanokontrol-working <--- this guy seems to have the same problem on an OSX... Hopefully there will be a fix the next days...

link

answered Apr 02 '14 at 19:08 by Nimmersatt (81)

Thanks for the information, my friends. Alas, I've still got no sounds in BW when I play the LPK with one of the synths, even with a custom controller script. I have an old CZ101 and a USB MIDI interface, I'll try that combination next.

Best,

dp

link

answered Apr 03 '14 at 12:57 by davephillips (76)

I couldn't find the power supply for my CZ but I did find my BCF2000, so I plugged it in and checked it out in BW. Huzzah, it works ! It was autodetected, the assigned faders work as they should, and I was able to apply MIDI Learn to various controls on the FM4 synth. So yes, USB MIDI does work on Linux, as others have reported, and now I know it works here too. Alas, I still have no idea why the LPK25 won't work, I'll continue my research.

Best regards,

dp

link

answered Apr 03 '14 at 13:27 by davephillips (76)

Another way to solve this is to use "virtual MIDI devices"-

found that solution here: http://answers.bitwig.com/questions/1218/how-do-i-get-midi-inout-of-bws-on-linux and here: http://linuxmusicians.com/viewtopic.php?f=47&t=12748

Works great! I was definitely frustrated with getting MIDI in and out of Bitwig, but now it's working great. Various MIDI devices in (device >> virtual midi device >> bitwig alsa controller script >> bitwig) and MIDI clock out (bitwig >> midi clock out >> virtual midi device >> various programs like qmidiarp)

link

answered Oct 30 '15 at 16:13 by cbfishes (51)

I'm having same problem in Windows 7. Axiom25 and NanoKey2 both showing up in preferences but won't trigger midi. Sometimes in the middle of a session they will suddenly work but next time I open Bitwig they won't. This is a recent problem probably only since v 1.3.8. I've disabled my controllers in other DAWs which didn't help.

link

answered Apr 01 '16 at 15:01 by Nigel (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×213
×88

Asked: Apr 01 '14 at 20:58

Seen: 11,282 times

Last updated: Jan 18 at 06:54