asked Apr 05 '14 at 17:26 by Kryuko (26)

edited Apr 05 '14 at 17:28

Same as title. I don't have audio on my Ubuntu 14.04.

Settings screenshot: http://screencloud.net/v/gw8R

Any solution?

What happens if you select default or sysdefault as output device? Do you have the option of selecting Jack instead of ALSA?

Jack is yet another audio server, that's especially suited for audio, because of low latency and advanced routing capabilities. I believe that Jack is a dependency of Bitwig, so if you have Bitwig running on a Linux machine, it should be installed. There are graphical user interfaces for setup, like QjackCtl and Cadence. You should be able to find QjackCtl in Synaptics Package Manager or even the Software Center. Here is something to read regarding settings and use: UbuntuStudio

There are often issues when trying to run Jack and Pulse together. If you do run into such issues, you could try Option 4 mentioned here, before you try more drastic measure, like killing Jack at start up and manually loading it when you need really it.

I would however suggest to go ahead and install either the Ubuntu Studio or KXStudio packages. Especially KXStudio comes set up pretty well for audio and includes a ton of audio applications and even some LInux VST plugins, which you can use right away in Bitwig.

link

answered Apr 06 '14 at 12:40 by Cyler (296)

I don't have any option for selecting jack instead of alsa =/

  — (Apr 06 '14 at 15:41) Kryuko

Then you should install QjackCtl, set it up and start up Jack first. You would do yourself a huge favour, if you upgarded to something like UbuntuStudio or right away KXStudio, which is much more suitable for audio.

What about choosing any of the other Audio Output options, like default and sysdefault?

  — (Apr 06 '14 at 16:20) Cyler

Already installed QjackCtl, but i don't see any options for it. If i choose other audio output options, nothing happened.

  — (Apr 06 '14 at 17:07) Kryuko

you can check for the jack-process via "ps -a | grep jackd". If there i a server running you can see a line with a number (pid) before jackd.

With qjackctl you can set up a jack server and start it, or connect to a existing sound server. I suggest you select your device in the qjackctl settings, then open up the Messages Window and click "Start"

The small display in the middle should show active if it is working. If it is not working, the Messages window should contain more information.

Feel free to post the output of the messages window here.

  — (Apr 06 '14 at 17:40) noreabu
1

Solved, thank you!

  — (Apr 06 '14 at 20:57) Kryuko

Btw. if it all runs fine under ALSA, don't worry about Jack until you really have a good reason to do so. I know that's not what I said earlier, but I just gave it a shot running Bitwig under ALSA instead of JACK and all the dropouts I used to get are a thing of the past. Until JACK transport is implemented, I don't think I will bother going back. Should give me some more time to figure how to get JACK running on my system without xruns.

  — (Apr 07 '14 at 11:39) Cyler

@Cyler do you use a "low latency" kernel?

My kernel is tagged like this: ? ~ uname -a Linux sys0 3.11.0-17-lowlatency #11-Ubuntu SMP PREEMPT Fri Feb 7 00:51:05 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

It is the default kernel for Ubuntu Studio (latest release with updates)

  — (Apr 10 '14 at 21:22) noreabu

Yes, I'm currently on 3.11.something low latency, but about to give it a shot downgrading to the 3.5 one. Was running 3.8, which comes standard with KXStudio, but got too many audio drop outs (xruns) for my taste. Apparently my Focusrite Scarlett has trouble with 3.8 and either 3.11 or 3.5 should play nicer. Well, 3.11 seems to cause even more xruns, but I reckon that's more to do with the NVIDIA drivers, so will have to give the 3.5 low latency kernel shot. My next audio computer will have a PCIe sound card and bog standard Intel graphic for that reason.

  — (Apr 11 '14 at 04:04) Cyler
showing 5 of 8 show all

What other output devices can you choose from? Maybe try a few different ones, if there are multiple options. Also check your output channel in the "Studio I/O" section of the browser (very right button on the bottom).

For what it's worth, both Input Device and Output Device on my machine are set to "system" and Audio System is "Jack Audio Connection Kit". That requires Jack to be installed and set up (that's where I choose my audio interface" and running though. Installing Jack makes a lot of sense, if you want to do a fair bit of audio tinkering on Linux. It allows you things like connecting different applications and if the application supports Jack transport, you can run them synchronized. Jack transport is not supported in Bitwig yet, but according to Dom it's on the list. Also, Pulse is prone to cause problems with Linux audio applications. My computers runs on KXStudio, which does not have Pulse installed at all, because of that. You can just disable Pulse on startup and only call it when you really need it. Killing Pulse is another option, but I found it to be quite persistent if not killed right on startup. Hope that some of that helps.

link

answered Apr 06 '14 at 03:36 by Cyler (296)

I have these options: http://imgur.com/ARqqSIg,PbjzUJi,6p4F8Ie,aLamNtt

In the Studio I/O i have this: http://screencloud.net/v/jYQX

What is Jack Audio Connection Kit? How can i install and configure it?

  — (Apr 06 '14 at 11:57) Kryuko

From my experience i strongly recommend using jack over pulseaudio.

The short and easy solution to this ist maybe just the installation of the "ubuntustudio-desktop" package. A lot of additional stuff will be installed, but i remember this to be the least annoying and time-consuming option on Ubuntu :)

If you want to set it up as a single package, check out this page (in german): http://wiki.ubuntuusers.de/jack

Basically the most important step is: sudo apt-get install jackd qjackctl

After that, you should work out a configuration for jack, either on the command line, or in qjackctl. After that, i recommend installing the pulseaudio Sinks and Sources for jack to be able to use every sound application on linux at the same time.

If you need more hints, i can provide you with more detailed information about my setup :)

link

answered Apr 06 '14 at 12:25 by noreabu (11)

I've installed "ubuntustudio-desktop" package, but i don't have any setting about jackaudio on Bitwig...

  — (Apr 06 '14 at 15:31) Kryuko

mine is set to pulse

link

answered Apr 10 '14 at 01:49 by korte1975 (96)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×126
×88
×26
×9
×3

Asked: Apr 05 '14 at 17:26

Seen: 4,079 times

Last updated: Apr 11 '14 at 04:04