asked Oct 26 '15 at 08:27 by syntheticzen (26)

Greetings, I have been running every version of Bitwig on my OpenSuse system successfully. Even the RC of 1.3.0 worked. But for some reason, the full release I can not get to work. I know you don't officially support rpm version of your product, but if you can please point me in the right direction, it would be very much appreciated (and I will help the number of others I know using rpm based distros using your products.

This is the error I get when trying to start it: bitwig-studio JRE Path: //opt/bitwig-studio/lib/jre Could not de-obfuscate stack trace: /home/bofh/.BitwigStudio/4624c1b52c2a9f8fa33f537c791263cfa064dd5f-Linux-release.txt not found. Could not de-obfuscate stack trace: /home/bofh/.BitwigStudio/4624c1b52c2a9f8fa33f537c791263cfa064dd5f-Linux-release.txt not found. java.lang.UnsatisfiedLinkError: /opt/bitwig-studio/lib/bitwig-studio/libx11-windowing-system.so: libbz2.so.1.0: cannot open shared object file: No such file or directory at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1938) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854) at java.lang.Runtime.loadLibrary0(Runtime.java:870) at java.lang.System.loadLibrary(System.java:1122) at FJe.NrQ(SourceFile:186) at com.bitwig.x11_windowing_system.X11WindowingSystem.NrQ(SourceFile:20) at com.bitwig.x11_windowing_system.X11WindowingSystem.<clinit>(SourceFile:14) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:264) at com.bitwig.windowing_system.wUd.wCC(SourceFile:151) at com.bitwig.windowing_system.wUd.<clinit>(SourceFile:42) at com.bitwig.flt.app.FloatMainApplication.QH(SourceFile:630) at bZB.hcl(SourceFile:73) at com.bitwig.flt.app.FloatMainApplication.hcl(SourceFile:657) at bVY.KOJ(SourceFile:1915) at bVY.NrQ(SourceFile:142) at bWq.run(SourceFile:866) at bVY.wCC(SourceFile:1230) at com.bitwig.flt.app.JrS.wCC(SourceFile:1368) at bVY.NrQ(SourceFile:1188) at bVY.ToH(SourceFile:870) at com.bitwig.flt.app.FloatMainApplication.main(SourceFile:6336)

I am running 64 bit OpenSuse 13.2 It seems to be looking for this: libbz2.so.1.0

And I have libbz2-1-1.0.6-29.2.7.x86_64, which contains: libbz2.so.1 libbz2.so.1.0.6

Suggestions?

Thank you for your great work, and continued support of the Linux community, it is greatly appreciated!

-Hawke http://syntheticzen.com http://techtalkhawke.com

Many thanks to Bitwig's responsive and helpful technical support through email!

It was just a simple symlink issue (because of being on a different platform than officially supported). I had already tried this under /usr/lib/, but it actually needed it in /usr/lib64 since I'm on a 64 bit version of OpenSuse 13.2

To summarize, on OpenSuse 13.2 64 bit

First made certain that libbz2-1-1.0.6-29.2.7.x86_64 was installed (confirmed). Then add symlink to /usr/lib64/libbz2.so.1 for /usr/lib64/libbz2.so.1.0 ln -s libbz2.so.1 libbz2.so.1.0

ln -s libbz2.so.1 libbz2.so.1.0

Cheers!

link

answered Oct 27 '15 at 23:17 by syntheticzen (26)

Ooh, you already threw that in here! Big thanks! :D

  — (Oct 28 '15 at 14:34) riot ♦♦

ln -s libbz2.so.1 libbz2.so.1.0

Works for me on Fedora 23 as well.

link

answered Apr 16 '16 at 16:08 by samtuke (11)

I had to not only do that link, but also install libbsd.

link

answered Jun 09 '16 at 09:31 by phorgan1 (11)

Merci pour votre aide, pour résumer fonctionne avec Fedora 25 with wayland server:

dnf install libbsd zfstream

ln -s libbz2.so.1 libbz2.so.1.0

link

answered Nov 27 '16 at 09:40 by jptuv (11)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×89
×25
×2

Asked: Oct 26 '15 at 08:27

Seen: 2,681 times

Last updated: Nov 27 '16 at 09:40