asked Dec 23 '15 at 21:42 by ambientium (21)

Hi guys,

I've got a serious problem with undo/redo function which causes I'm unable to use Bitwig at all. I need undo/redo function when working with clips. I edit notes, or change the quantization, and cannot undo. WTF? In 21st century no undo/redo here? Or, another case, I accidentally moved a clip to another track and I wanted to undo. Impossible. W T F?

Shall I turn it on somewhere? Or is it not present in Bitwig? Is it in a todo list? All other daws have this function, in fact I don't have to think where I am and what I do, because I can just press CTRL+Z and any operation in DAW studio gets reverted.

You know, I can't make music without this function. How could I experiment without this? So, I must go back to Ableton for now. Sorry. Please let me know if you will add this function, because if you don't, I'll have sell my licence.


Lubos | ambientium

I have BWS 2.1 and exactly the same issue. A NEW PROJECT starts fine. But within maybe 4 tracks, VSTs or not, the UNDO stops working. It seems a little thing. But it's not when you get to a point in a project where the UNDO/REDO function are frequently used. BWS still blows my mind though. Crackles as well, usually with the brilliant free TyrellN6 VST when I play lower notes. It's hard to integrate from a decent start point with some VSTs and I'm not sure where the issue lies with this. Sorry...that's a separate question isn't it! The UNDO/REDO...any fix would be appreciated. Jamis.


answered Jul 30 '17 at 18:43 by Jamis (11)

I'm talking about arrange mode....


answered Dec 23 '15 at 21:48 by ambientium (21)

This was a bug in a 1.3.x version, that was fixed. Are you using the latest?


answered Dec 23 '15 at 21:55 by svervs (142)

I was using the latest version downloaded that day, I guess 1.3.5. But I figured out that I have still installed the 1.12 BETA version. Even if I was running 1.3.5, the bug was there. I uninstalled 1.12 BETA and suddenly all is right. Thanks a lot for your help.

  — (Dec 24 '15 at 16:18) ambientium

Im having same issue now, no Undo at all. Whole issue started when I pluged new keyboard I think. Dont have old one to test it though. Kinda painful.... CTRL+Z works fine elsewhere. Edit: Relunching bitwig doesnt help.

Edit #2: It works now, maybe restarting PC fixed it, gonna give info if I will have same issue and restart will help.


answered Jul 28 '17 at 21:19 by kamilpawlak (51)

edited Jul 28 '17 at 21:27

Please tell us what version you are using.


answered Jul 29 '17 at 19:27 by amg56 (657)

1.3.16, but as I said, restarting whole PC fixed it.


answered Jul 30 '17 at 13:14 by kamilpawlak (51)

Same problem here in 2020 with 3.1.1


answered Jan 13 at 21:34 by Orik (11)

Same here 2020 too. It makes me sick!

I tried to re-mapping shortcut, but Ctrl + Z doesn't work and Ctrl key works with every other key!!! Except "Z" key.

Undo button still fine. I'm using 2.4.3

Please help me


answered Feb 10 at 08:52 by SY (11)

Hi there, don't know if it is the same prob, but UNDO does not work during play back at all. It works when the song is stopped.

I would need this desperately when overdubbing into an existing MIDI-Clip for live looping. Within Ableton this is a no brainer. But no way in Bitwig!?

I have to stop the song, then I can undo every step. But for me this is useless.

I am new to Bitwig and use the latest versdion. You WILL have to add that feature. For performing live it is simply essential.

Or am I missing something?

Regards Lorenz


answered Mar 04 at 11:41 by Lorenz (21)

edited Mar 04 at 11:42

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Dec 23 '15 at 21:42

Seen: 2,619 times

Last updated: Mar 04 at 11:42