asked Jan 18 '16 at 00:41 by chilango (26)

I literally just bought a license for Bitwig and I'm trying to send midi to my modular synth via a Scarlett 2i (midi driver: none), but I can't. I've found many posts on the web of people having these issues, some of them fairly recent ones. While I'm aware that the inability to send midi out using a hardware instrument is a known bug (and is apparently fixed in 1.3.6), I'm confused about how to route my midi via jack (using Linux).

When I load the snd_virmidi module, I can see the virtual midi ports being created, but they don't match the ports I can see in Bitwig's hardware instrument.

Please see this screenshot.

There are four ports being created in qjackctl, and I can see them in Bitwig's hardware instrument too. However, each port in Bitwig has the usual 16 channels (so I have all combinations of Virtual Raw MIDI [1/4] [1/16] available), but in jack each port has only... one channel? Is it the case that each port has only one channel open (0 in jack's index)? If so why do I see the remaining 15 channels as options in the hardware instrument? This is confusing because in Live you can only see the in/out ports options that you have specifically enabled in the options.

Another confusing issue is that when I select which channel I want to output in the hardware instrument, the "ch.1" indicator doesn't change to the channel I just selected. What gives?!

Any pointers appreciated.

You shouldn't have to touch virtual raw midi with USB midi devices in Bitwig as it recognises USB midi natively. I've had to use virtual midi on my system to get it to work with my Firewire sound module which has midi in/out, currently this is not directly supported in Bitwig so you have to use virtual midi and Alsa to Jack midi bridge to get it working. However this is not your issue. Just add a hardware instrument as belowalt text

Obviously my setup is not the same as yours but I've used a USB midi device in the screenshot to illustrate this. Under midi out is a selector box to choose which USB midi port you wish to use, below that is the channel you want to send Midi on (just click and drag with the mouse to change the channel)

If you want to send midi into Bitwig using USB you go to the Options/Preferences/Controller window. If it's a generic controller you will have to add it manually and then select which USB midi port you wish to use.

alt text

link

answered Jan 19 '16 at 14:15 by Strangetown (69)

I guess I was too tired yesterday :) thanks for the pointer.

You shouldn't have to touch virtual raw midi with USB midi devices in Bitwig as it recognises USB midi natively.

If I want to send CC data from PureData to Bitwig, I would need to use virtual raw midis ports... right?

  — (Jan 20 '16 at 05:49) chilango

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×25
×18
×3
×1

Asked: Jan 18 '16 at 00:41

Seen: 1,494 times

Last updated: Jan 20 '16 at 05:49