asked May 30 '16 at 21:11 by io (127)

Something is causing stuttering underruns during playback while using JACK audio drivers. In the messages window of QjackCtl they appear as such:

11:24:28.055 XRUN callback (5 skipped).
11:24:30.061 XRUN callback (8 skipped).
11:24:32.071 XRUN callback (3 skipped).
11:26:26.376 XRUN callback (254).
11:26:28.485 XRUN callback (4 skipped).
11:26:28.756 XRUN callback (260).
11:26:30.494 XRUN callback (6 skipped).
11:26:32.502 XRUN callback (2 skipped).

etc... They seem to occur at the beginning/end of clips, indiscriminate between midi/audio, inconsistent occurrences.

Here are some relevant hardware specs:

CPU:

  product: Intel(R) Core(TM) i7-4800MQ CPU @ 2.70GHz
  vendor: Intel Corp.
  physical id: 1
  bus info: cpu@0
  size: 3500MHz
  capacity: 3700MHz
  width: 64 bits

Interface:

 product: FiiO USB DAC-E17
 vendor: FiiO
 physical id: 1
 bus info: usb@3:1.4.1
 version: 0.01
 capabilities: usb-1.10
 configuration: driver=snd-usb-audio maxpower=500mA speed=12Mbit/s

Update: I was able to essentially emulate a kxstudio environment by installing cadence which gives some visual feedback on drivers/kernel/latency. I also installed a lowlatency kernel the lazy way: sudo apt-get install linux-lowlatency to snag the 'recommended' kernel, although you could probably get away with downloading the right one off of kernel.org, if that's your thing. This link to the mint forums should tell you everything you need to know. Including the editing of the /etc/limits.conf file, it's not too hard just pay close attention to the instructions.

After all that, I still couldn't get sound to come out of bitwig, but crazily enough, opening the reinstalled qjackctl and selecting my soundcard from the dropdown made sound instantly worked (also jack is not throwing the dbus errors I was getting alongside my previous xruns). Note: this didn't seem to be affected by pulse audio, despite what many things on the net said, but did uncheck "autostart at login" in cadence just in case.

disclaimer: since I don't have a filled out project to test playback on all I can confirm is that according to cadence I am operating in realtime and I'm able to get sound coming out of bitwig. Assume the stuttering has been solved unless I return saying otherwise.

big ups!

EDIT: Ok So after tinkering around with things the past few days, trying to figure out why cadence says it's working in real time, and qjackctl says it's running no problems, but chrome was having issues. Cadence does this really awesome thing that basically "daisy chains" Alsa > Pulse > Jack in what it calls a bridge. after getting the jack bridge settings just right, I still wasn't getting any sound form chrome. What worked for me was to install the jack-pulse-module (not sure if that's it's formal name) to get pulseaudio to play nicely with cadence (after that cadence could start up the pulse audio server). And then after that installing the Java development kit 8 (which I finally did as part of the Push4Bitwig setup, following Mossgraber's tutorial here under linux installation) and then suddenly i can hear audio from youtube videos and soundcloud. The only thing left to answer is if there will be underruns in the future, but that's to see during my next project (note that the push4bitwig display might have been causing the underruns from my OP? not sure.)

link

answered Jun 05 '16 at 09:33 by io (127)

edited Jun 10 '16 at 05:27

Well for starters I wouldn't use QjackCtl as imo it's buggy. I've had troubles with it crashing when trying to set up Alsa to Midi bridge.. Instead use the Cadence Gui as provided by Kxstudio. It may not necessarily be related to your problem but is definitely more stable.

KXStudio : Repositories

link

answered May 31 '16 at 15:17 by Strangetown (69)

edited Jun 14 '16 at 15:27

Thanks for the response. I performed a fresh install of mint, hoping that would clear any problems up. Unfortunately I screwed up the backup (4am+rum) and lost the only project I made (utter despair) to re-create the problem. I'll come back with an update in a couple of weeks, hopefully it will have solved itself.

And thank you for the recommendation for carla, it seems more robust than qjackctl. Being new to linux audio some things still go over my head, though. mint's synaptic package manager was a wonderful graphical solution for getting carla set up.

  — (Jun 02 '16 at 09:47) io

Instead of using Mint I would recommend using a dedicated multimedia distro like Kxstudio itself or Ubuntu Studio It may be that herein lies the original problem as you need to install a realtime kernel with a standard distro and also manually edit the file /etc/limits.conf to enable realtime capability. See here. Multimedia distros when installed come with this pre-configured. Ubuntu studio comes with the Xfce gui as default. Kxstudio comes with Kde. The former uses less system resources. I personally prefer it as it is simple and easy to get to grips with, however if you decided to use Kxstudio as your installation and didn't like Kde you could always install Xfce and use that instead as the default gui.

An addendum: Synaptic package manager is not just shipped with Mint but is a commonplace front-end for the apt command-line package utility. If for some reason it isn't installed on whatever distro you choose you can always install it later.

link

answered Jun 02 '16 at 11:47 by Strangetown (69)

edited Jun 03 '16 at 03:17

I'm on my 3rd setup since first installing linux a month ago. I'm reaaaally hesitant to throw even more work/setup hours away. I don't mind editing a config file, as long as the instructions are specific. The problem is most solutions online are at least 1-2 years old, so they suffer form accuracy decay. I found this article on the mint forums, hopefully it works, I'll updatewith results: https://forums.linuxmint.com/viewtopic.php?f=42&t=178572

  — (Jun 03 '16 at 10:23) io

I was successfully able to get realtime processing enable with the help of that guide. All the sound on my computer works except for bitwig, probably something I have to switch/turn on, just don't know what yet. Anyway, leaving this small update here before I head to sleep.

  — (Jun 03 '16 at 11:36) io

I was merely trying to save you some trouble by recommending a multimedia distro. anyway nice result! :)

  — (Jun 03 '16 at 11:41) Strangetown

I appreciate your input! It certainly pointed me in the right direction. :D

  — (Jun 05 '16 at 09:12) io

Edited first post to read 'Cadence' instead of 'Carla' only just noticed my mistake lol. The former is the alternative gui to jackd, the latter is a modular 'rackmount' multi fx gui.

link

answered Jun 14 '16 at 15:33 by Strangetown (69)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×89
×18
×2
×2
×1

Asked: May 30 '16 at 21:11

Seen: 1,358 times

Last updated: Jun 14 '16 at 15:33