asked Jul 14 '16 at 15:01 by cbfishes (71)

2
1

Very strange issue here... Running Bitwig on Linux (KXStudio). Long story short: When Bitwig is running, it doesn't have its own icon in my dock, taskbar, or anything else.

More details: It looks like there are two processes that run Bitwig; one is /opt/bitwig-studio/bitwig-studio and the other is /opt/bitwig-studio/bin/BitwigStudioEngine

I can edit the 'Bitwig Studio' .desktop file in /usr/share/applications/ to change the icon of the BitwigStudio process, but creating a .desktop file for the engine does not change anything. In my dock, taskbar, and window switcher, for Bitwig I just see a default icon (looks like a window with nothing in it).

Anybody else having this issue? It's a very minor one- doesn't affect using Bitwig at all, except trying to find it in a taskbar full of other icons.

Doubling this question. Same behaviour with my linux box. I played with different StartupWMClass attribute in desktop file but that does not help.

xprop gives me "" and "Bitwig Studio" WM_CLASS but setting StartupWMClass to this in desktop file don't help my launcher (Docky) to recognize Bitwig window.

UPDATE Found solution - remove quotes from Exec line of file /usr/share/applications/bitwig-studio.desktop

link

answered May 16 '17 at 15:31 by zezic (21)

edited Jul 26 '17 at 19:58

My solution (Ubuntu 16.04 vanilla) was to comment out the StartupWMClass line in /usr/share/applications/bitwig-studio.desktop.

link

answered Aug 20 '17 at 15:29 by grimus (11)

@zezic points to the right direction

On Ubuntu (Studio) 18.04 in file /usr/share/applications/bitwig-studio.desktop

StartupWMClass=Bitwig Studio

it should be without quotes (") to work for me


UPDATE this only worked until rebooting and then was not possible to be reproduced :(

link

answered Jan 21 at 22:14 by fas-bitwig (21)

edited Jan 25 at 16:48

Finally, I have a Bitwig icon that stays in Plank using absolute icon file path and the following settings in

/usr/share/applications/bitwig-studio.desktop

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
StartupNotify=true
Icon=/usr/share/icons/hicolor/scalable/apps/bitwig-studio.svg
Name=Bitwig Studio
Comment=Music Application
Exec="/usr/bin/bitwig-studio"
Categories=Multimedia;AudioVideo;Player;Recorder
MimeType=application/bitwig-project;application/bitwig-template;application/bitwig-package
StartupWMClass=Bitwig Studio

Cheers!

link

answered Feb 25 at 11:08 by fas-bitwig (21)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×118
×32
×6
×1

Asked: Jul 14 '16 at 15:01

Seen: 1,788 times

Last updated: Feb 25 at 11:08