asked Nov 13 '16 at 01:18 by amg56 (505)

edited Nov 13 '16 at 01:18

I have compressors from several manufacturers that act in a really unexpected way when inserted on a channel that carries MIDI information in Bitwig. FabFilter Pro-C 2 gets forced into maximum compression when it receives a MIDI note. If you disable Pro-C, you can see on its graph and meter that now it's compressing properly. This in itself is a secondary problem, because it means that the plugin is still processing and eating up CPU. In all the other DAWs, when you disable it, Pro-C's meter goes flat, which is what it should be doing. Anyway, after some fiddling around I found out that I could put a Note Receiver in front of the compressor, mute the note receiver to strip out the note data, and then suddenly the Pro-C is compressing properly. Another way of doing this is to disable the MIDI listen feature inside of Pro-C, however this is still weird because the manual doesn't say anything about note data triggering compression. The MIDI listen on Pro-C, as far as I know, is only intended to map CC's to the controls - no notes. So there are a bunch of problems here.

UAD's Neve 33609, one of my favorite compressors, had a slightly different behavior. It appears to be working fine when enabled. When disabled, the MIDI notes force the comp to maximum compression. In the process, the CPU gets spiked because of whatever oddity is now going on with the comp's code that it wasn't designed for. You can literally watch the meters on the Neve plugin jump and come back down together with the length of the MIDI notes. Again, this shows that, when bypassed, the audio is still being sent to the plug and the plug is processing away, wasting resources.

I think that the signal path should be such that, if Bitwig sees an effect placed after an instrument, it should cut off the MIDI data flow at that point, and give the user the option to manually enable it. Possibly even better, the midi instrument itself should not even be passing the MIDI data downstream at all. It should act like a MIDI out and not a MIDI through. The situations where you want your MIDI data targeted at the instrument to flow any further downstream are very few, and can be addressed manually by setting up a note receiver. As it is now, you are forced to remind yourself to put in a muted receiver just to block the MIDI every time it can cause unwanted behavior in the VST effects, which is very often. It's unwanted extra work.

link

answered Dec 01 '16 at 02:02 by amg56 (505)

After using it some more, I really think the instrument block should have an additional switch that is set to MIDI OUT by default and would allow the user to set MIDI THROUGH if needed. This problem that you can inadvertently send midi data that opens and closes compressors can be a real headache if you added one of these devices without soloing and you get all the way down to mastering to figure out that something in the background was popping.

  — (Dec 10 '16 at 21:07) amg56

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×206
×49
×43
×25
×22

Asked: Nov 13 '16 at 01:18

Seen: 639 times

Last updated: Dec 10 '16 at 21:07