asked Nov 19 '16 at 20:39 by amg56 (697)

If I put up an instance of Geist2 and follow it with a UAD Neve 33609, then disable the Neve with Bitwig's component disable button in the rack, the audio breaks up. It only occurs under some conditions, and I'm not quite able to figure out exactly what's the situation that creates the problem, I put in a Drumazon and also followed it the Neve compressor, and it wasn't doing the same. At this stage, the compressor with Geist started working ok when disabled as well. It seems like it's something having to do with the latency compensation not being reset properly when the UAD plug is disabled. If I disable the plug with the switch that UAD provides inside the plugin itself, there is no problem. I have two projects, one of which I started from scratch to test this, the other one a full composition, where the UAD plug has been doing this.

Oh wait, this is the same problem I found previously with MIDI data being passed to the UAD compressor. I put a note receiver in front of it to strip out the incoming MIDI notes and it started working as expected.


answered Nov 19 '16 at 20:42 by amg56 (697)

This is still valid in Bitwig 2.0.

When an UAD audio FX plugin is bypassed in Bitwig (UAD Helios 69 EQ in my case) there will always be an (extremely annoying) crackle when starting playback.

This kind of kills the process because you constantly want to bypass/unbypass FX plugins and stop/restart playback to A/B test the difference the plugin makes.

The issue indeed goes away when putting a Note Receiver in front of the UAD plugin. (probably as written in the post above by preventing midi notes from reaching the plugin).

Of course this is not a solution because it's very inefficient in terms of workflow to put a Note Receiver on each track where you want to use a UAD plugin.

It might be a UAD issue but since Bitwig is used professionally these days and UAD is considered pretty much a standard at this point I think Bitwig should provide a solution in any case.


answered Mar 15 '17 at 07:45 by norbert (120)

edited Mar 15 '17 at 07:58

Others experiencing the same issue:

Also found a UAD Bitwig "auto-suspend" issue. This is not it, changing auto-suspend has no effect on this but adding a Note Receiver before the UAD plugin does.


answered Mar 15 '17 at 07:57 by norbert (120)

edited Mar 15 '17 at 07:58

I have been lobbying to get a solution to this issue during the beta 2 phase. So far no luck. One problem appears to be that the Bitwig development team sees this strategy of allowing midi data to flow down the rack as a major advancement, which it actually is given all automation devices they are creating.

However they did not take into account how this change would impact on preexisting workflows. Both the UAD plugs and the Fabfilter compressors will want to interpret this incoming midi data (which is intended for the synth in front of them) as on/off messages. That is a massive workflow downer. Even though I found the workaround, when I'm working quickly I sometimes forget about it and then I have to backtrack to figure out where the crackling is coming from. So I hope the dev team thinks clearly about this one and puts a switch on the instrument blocks to disable the MIDI through, and a user preference for people to choose the behavior that best fits their default workflow, as was discussed on the beta group.


answered Mar 15 '17 at 16:21 by amg56 (697)

Actually it is probably a good thing that midi note information is passed to all devices on a track because likely this is what makes things like the ADSR modulator possible (which needs midi note information inside a device down the chain to be able to retrigger on every note).

What would be great is if there was an option on a per plugin basis to suppress midi note information for that particular plugin. Ideally this should be set once for each plugin and remembered forever. Either in preferences or a toggle within the device container (although it would be global and permanent, so preferences seems like a better place for it).

Hope all of the above helps the Bitwig team understand and address this issue.


answered Mar 15 '17 at 19:03 by norbert (120)

Oh no, like I was trying to say, I understand why they did it. But they needed to take care of the repercussions properly.


answered Mar 16 '17 at 02:30 by amg56 (697)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Nov 19 '16 at 20:39

Seen: 1,343 times

Last updated: Mar 16 '17 at 02:30