asked Dec 29 '16 at 12:05 by Ton-ish (483)

edited Jan 04 '17 at 13:04

In Bitwig I'm experiencing very high CPU usage when i use the Asio driver for my soundcard, but when i open the DSP graph window the CPU drops back to normal. Here is a picture of what happens when i open it

alt text I guess Bitwig takes CPU priority when we open the DSP graph. I wonder if you have any tips or windows tweaks that could help me have a better CPU behavior?

When i use the Wasapi driver I don't have any CPU problem but i have no inputs available from my sound card.

| | |

Make sure you have priority for 'background processes' enabled in Windows (like se: http://www.thewindowsclub.com/processor-scheduling-in-windows-7-8).

Make sure, your power management profile has min. CPU frequency at sufficiently high level (50% or more) - for balanced profiles its usually at 5%, which is a killer for real-time audio applications, because when utilisation of the CPU is low - say 20-30% - the system will reduce the clock so that the power doesn't go to waste and that's when glitches occur.

Install a tool - eg. full throttle override (http://tringi.trimcore.cz/Full_Throttle_Override) - that'll adjust the power profile to max performance as soon as specified programs are run, so that you don't have to do it manually.

Disable internet, antivirus, system updates, notifications while working in Bitwig.

I also had that issue (drop in reported CPU load when opening the DSP graph) and the above solved it - not sure which one, though :)

link

answered Sep 20 '17 at 10:35 by antic604 (379)

edited Sep 20 '17 at 10:36

I found out today, what caused theese spikes, cause i had them too in some projects. when i used Mc DSP CompressorBank CB101, i had these spikes too and at the same peak load of 32.767 ms. Always out of nothing. I just tryed one loop with this plugin and this problem also exists. Even when i don´t press play, the spikes are showing up. So i don´t know, if this is a situation with all mcdsp plugins, but i won´t use these, when i work in bitwig. Let me know, if you where using also mcdsp. I try to adress this to the technical support.

cheers

link

answered Feb 28 at 20:14 by trybwguy (169)

The usual way to solve it is to increase your audio latency. If you post more information about your setup (operating system, computer, audio interface etc) you could probably get more detailed help. :)

link

answered Jan 04 '17 at 12:28 by fredrik (90)

Thank you, I have a Dell Xps13 windows 10 64bit and an Iconnect Audio2+ set to the recommended buffer size: 800 samples, as shown on the picture above. Due to coil noise i have to set my computer battery plan to "Power Saver" mode and i'm pretty sure that's where the problem comes from. But is that normal that when the DSP performance graph is open, Bitwig's performances are more stable? If yes, is there a way to keep it open by default?

link

answered Jan 04 '17 at 12:52 by Ton-ish (483)

edited Jan 04 '17 at 12:53

I experienced the same strange behavior. I run Bitwig on a Win 10 Laptop with no external soundcard. I can only chose the wasapi driver and can´t adjust sample rate and buffer. With the DSP Performance Graph open all runs very smooth. If closed it get´s overloaded very often and makes it all unusable. That´s already happening when DSP Graph shows about 30% load. Didn´t experience this behavior on my older Laptop with internal sound.

link

answered Sep 19 '17 at 18:07 by SUMTRAX (41)

ok, thanks for the reply. Setting the priority didn´t help. But setting the "minimum processor state" to a way more higher level helped.

(how to: see here)

In my case 75% gave me enough air to breathe. No need to have the DSP graph open at all times anymore. Saving it as a power plan lets me switch it on and off if wanted. Still I have no clue why the DSP graph did the same as setting the "minimum processor state" to 100%...but if it´s working now I don´t really bother ;)

link

answered Sep 20 '17 at 17:11 by SUMTRAX (41)

I can attest that the highest-voted answer given by @antic604 is still relevant today in 2.3.5. Either leave your Windows 10 machine constantly running in the High Performance power plan (or the newer Ultimate Performance plan available only on desktops running Windows Workstation--not Windows Home or Windows Pro), or find a utility that enables you to run in the Balanced power plan most of the time but will automatically kick you into High Performance mode when you run specific programs like Bitwig.

If your machine is running in anything but the High or Ultimate performance mode, you will get this severely spiky CPU behavior in Bitwig unless you have the DSP graph sitting open at all times.

Two such utilities that I know of are "Full Throttle Override"by Jan Ringos, and "Process Lasso" by bitsum. Full Throttle is a wee bit confusing to set up and run properly (you must always run it as Administrator or it won't work correctly), and it does tend to crash itself every few days and stop working until you restart it. Also, I'm guessing that it does not take advantage of the newer Ultimate Performance mode available in Windows Workstation. Process Lasso, by contrast, is very well-documented, constantly updated, and still relatively inexpensive. And it has always offered the equivalent features of Ultimate Performance mode in every edition of Windows 10.

link

answered Aug 06 at 14:13 by Baphometrix (139)

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×22
×12
×5
×5

Asked: Dec 29 '16 at 12:05

Seen: 1,688 times

Last updated: Aug 06 at 14:13